Toad World® Forums

Importing from clipboard in 10.6.1.3 Commercial

I’m trying to import data from the clipboard into a wide table (using 44 columns out of 422). In Toad 9.5, if I had the first row set up containing the appropriate column names, Toad would map the data to those columns automatically. In Toad 10.6 it’s not doing this - it automatically selects the first 44 columns of the table. Furthermore, the field picker only shows 200-odd columns, so I can’t select the correct field for many of the columns I’m importing. I have to pick the ones I can see, then on the final screen set the mappings for the remainder, which is a very tedious process.

Needless to say, I’d prefer not to have to use even the field picker, and just have it pick up the field names automatically from the header row like it used to. I noticed in the help file that it says there is an option to do this if importing from XLS. Is there a way to access this option when importing from the clipboard as well?

Hi Scarlet,

I’d have to say this is a bug. I’ll fix this. Can you get your data inot excel to map the mapping easier?

-John

Yeah, in the end I just saved it as an Excel file and loaded it from there - much faster than picking all the fields.

Mind you, the reason I did that was because after I picked all the fields manually it ran the import process but imported 0 rows. I think the clipboard must have been emptied in the course of getting the field mappings sorted out.