Toad World® Forums

Instance ID on RAC after reconnect


#1

Toad 13.1.0.78: On RAC environment, TOAD shows instance ID at the connection info. When you are disconnected from network and press Session -> Reconnect, instance ID remains, but you can be signed to different instance ID (load balance on RAC). Instance ID is wrong in this situation.


#2

Thanks for letting us know. Our Support/Dev team members will pick this up, if they haven’t already documented the issue from others, and prioritize for resolution in our release map.


#3

prioritize for resolution in our release map.

That’s awfully formal. I decided to just fix it. :slight_smile:

I tried to reproduce this by:

  1. Make a connection to a RAC instance (It gave me instance #1)
  2. disconnected that session from another copy of Toad.
  3. In the first copy of Toad, clicked Session -> Test Connections.
  4. I was reconnected to instance #2, and the [2] was indicated on the connection button.

Can you provide some more detail? Where in Toad are you seeing the wrong instance # shown?


#4

I got this error from my colleague. I tried to reproduce it too few minutes ago, and it was working well on my TOAD 12.12.0.39
My colleague is on vacation now, he will be back in 2 weeks. I am going to ask him to try to reproduce it again on his TOAD 13.1.0.78 when he will be back. He is very experienced user, so I didnt checked it - I am sorry for that, next time I’ll check every reported bug from my colleagues before posting them here.