Toad World® Forums

Issue with Team Coding and Compiling Package Body

I am running the latest Beta (14.1.114) and get stuck in a loop when compiling a Package Body. Here are the steps I go through:

1 - In Team Coding Manager I checked out the Package which checked out the Body as well.

2 - From the Schema Browser I selected Load in Editor which created a tab for the Package Header and Package Body under Edit.

3 - Made some changes to the Package Body

4 - Move the cursor to right before the CREATE OR REPLACE PACKAGE BODY... statement

5 - Press F9 to compile

6 - I get this popup: image

7 - I press OK

8 - The Merge Files window appears and I select all the deltas from the left pane containing my edits as shown below:
image

9 - Click OK

10 - In the Output section get the following message letting me know the Body was not Compiled:
image

This basically takes me right back to step 5 and the process just loops with my changes never getting compiled.

The workaround I have found is to press F5 and Compile as a Script. The down side of this is it constantly Checks out and re-checks in the Package every time I compile. My desire is to check it out, make changes and test, then once all is well check the Header and Body back in.

Hi Michael,

I believe I was able to reproduce the issue you're seeing here; however, I was only able to do so by enabling the "Format objects" option within the DDL Options page of Team Coding's configuration window. Do you happen to have that option checked? If so, try also checking the option underneath it to "Remove formatter comment" if that's unchecked.

The formatter puts a comment with a timestamp of when the format happened. This value will change every time the DDL is accessed which can cause the dialog you're seeing. Checking the option to remove the formatter comment will still allow the formatter to format the DDL, but should keep the timestamp from being included.

Let us know if that helps resolve the issue you're seeing. If not, let us know if you've customized any of the DDL Options within Team Coding's settings. That may help identify the cause of the problem you're seeing.

Thanks,

-John

1 Like

John,

That resolved my issue.

Thanks,
Michael