Toad World® Forums

List index out of bounds (538976288) when exporting dataset to Excel


#1

Toad Beta 12.8.0.26

This only happens when the dataset contains a date.

To replicate, try this: Select sysdate from dual; Then right click in the data grid, choose Export Dataset, format Excel File, click OK.


#2

Tried that to to XLS and XLSX, network or not network. No problems with saving.

Also the option “Display all results in grid” does not make any difference (as did in the past).

From: NoDabble [mailto:bounce-NoDabble@toadworld.com]

Sent: Friday, 11 September, 2015 10:12

To: toadoraclebeta@toadworld.com

Subject: [Toad for Oracle - Beta Discussion Forum] List index out of bounds (538976288) when exporting dataset to Excel

List index out of bounds (538976288) when exporting dataset to Excel

Thread created by NoDabble

Toad Beta 12.8.0.26

This only happens when the dataset contains a date.

To replicate, try this: Select sysdate from dual; Then right click in the data grid, choose Export Dataset, format Excel File, click OK.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Wim de Lange

Senior IT expert

ALcontrol Laboratories

Steenhouwerstraat 15

3194 AG Rotterdam NL

Tel +31 10 23 14 724 • Mobile +31 65 15 34 387

Fax +31 10 41 63 034

e-mail W.deLange@alcontrol.nl •
www.alcontrol.com

  • The information in this e-mail is confidential and may also be legally privileged.The contents are intended for recipient only and are subject to the legal notice available at: www.alcontrol.nl. Registered Office:Alcontrol BV, Steenhouwerstraat 15, 3194 AG Rotterdam.*

#3

Weird. Thanks for trying. I’ll see if I can replicate my issue on another PC.

For what it’s worth I’m running MS Office Professional Plus 2010, Excel v14.0.7153.5000 (32-bit)


#4

I use 64 bits Toad with 64 bits Office 2013 without the mentioned problem

From: NoDabble [mailto:bounce-NoDabble@toadworld.com]

Sent: Friday, 11 September, 2015 12:25

To: toadoraclebeta@toadworld.com

Subject: RE: [Toad for Oracle - Beta Discussion Forum] List index out of bounds (538976288) when exporting dataset to Excel

RE: List index out of bounds (538976288) when exporting dataset to Excel

Reply by NoDabble

Weird. Thanks for trying. I’ll see if I can replicate my issue on another PC.

For what it’s worth I’m running MS Office Professional Plus 2010, Excel v14.0.7153.5000 (32-bit)

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Wim de Lange

Senior IT expert

ALcontrol Laboratories

Steenhouwerstraat 15

3194 AG Rotterdam NL

Tel +31 10 23 14 724 • Mobile +31 65 15 34 387

Fax +31 10 41 63 034

e-mail W.deLange@alcontrol.nl •
www.alcontrol.com

  • The information in this e-mail is confidential and may also be legally privileged.The contents are intended for recipient only and are subject to the legal notice available at: www.alcontrol.nl. Registered Office:Alcontrol BV, Steenhouwerstraat 15, 3194 AG Rotterdam.*

#5

Just a thought. What is the date and time format you are using? Maybe that has an influence on the error.

From: NoDabble [mailto:bounce-NoDabble@toadworld.com]

Sent: Friday, 11 September, 2015 12:25

To: toadoraclebeta@toadworld.com

Subject: RE: [Toad for Oracle - Beta Discussion Forum] List index out of bounds (538976288) when exporting dataset to Excel

RE: List index out of bounds (538976288) when exporting dataset to Excel

Reply by NoDabble

Weird. Thanks for trying. I’ll see if I can replicate my issue on another PC.

For what it’s worth I’m running MS Office Professional Plus 2010, Excel v14.0.7153.5000 (32-bit)

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Wim de Lange

Senior IT expert

ALcontrol Laboratories

Steenhouwerstraat 15

3194 AG Rotterdam NL

Tel +31 10 23 14 724 • Mobile +31 65 15 34 387

Fax +31 10 41 63 034

e-mail W.deLange@alcontrol.nl •
www.alcontrol.com

  • The information in this e-mail is confidential and may also be legally privileged.The contents are intended for recipient only and are subject to the legal notice available at: www.alcontrol.nl. Registered Office:Alcontrol BV, Steenhouwerstraat 15, 3194 AG Rotterdam.*

#6

My sysdate looks like this: 11/09/2015 11:52:19. I can export to an Excel instance but not an Excel file.

I have tried it on Toad 12.5.1.1 using the same export settings (where possible) and it saves the file just fine.

There is another Excel Export issue with 12.8 beta which may be related… If I export the results of this query…

Select owner, object_name, Timestamp, status

From dba_objects

Where Rownum < 10

…to Excel it saves the file, but when the file is opened Excel switches to Protected mode with the following message in red at the top: Office has detected a problem with this file. Editing it may harm your computer.

Doesn’t happen with 12.5.1.1!


#7

I can reproduce the problem in 64 bit when exporting using the “Excel File” option to XLS, but XLSX works correctly. I’ll let you know when I have a solution. It works fine in 32 bit.

Just so you know - the version of Excel makes no difference for the “Excel FIle” format. Excel does not even need to be installed for it to work (but it does for “Excel Instance”). As you might have guessed, the “File” and “Instance” export options use completely different technologies. Also, XLS and XLSX export formats are very different, so if it fails in one, it may work in the other.

We just recently updated our Excel file writer component, so there may have been some problem there, but in my testing, I was able to export a million-row dataset (including dates and timestamps) without any errors. This many rows usually caused problems in prior versions.


#8

Fixed for next beta.


#9

You’re right… saving as xlsx solves both of my problems. I’m happy to do that as a workaround. Thanks.