Toad World® Forums

Nav 6.2. Annoying syntax hint. How to turn it off.


#1

Hi guys! Does anybody know how to turn off this annoying syntax hint which pop-ups every time when the mouse pointer goes over the line. Say, I have lRec1 and lRec3 which are an instances of a types T1 and T3 respectively. I type some assignments like lRec.f1 := lRec2.f3; Every time mouse pointer goes over this line I can’t see anything except of boxes like that:


  lRe1  T1 := COVT_AUD_ASSIGN_OUT_REC (NULL, NULL,NULL,NULL, NULL,NULL);

Is it possible somewhere to turn this “help” off?

  1. At the same time in 5.x version I was able to use “dot” help like if you type dot after

lRec1. and you’ll get a drop-down list of all type attributes.
Now [6.2] …it does not work.

Any suggestions?

Thanks, Michael


#2

Hi Michael,

Unfortunately, there is no way to turn off the syntax hint, that would be an enhancement request. I would suggest an alternative solution also: the hint should disappear after a short delay (say, 1 sec).

Dot lookup works in 6.2 as soon as the preference is enabled, and we believe that in general Code Completion in 6.x is far better than in previous versions. We’ve done a lot of work in this area. Please make sure that the preferences (Code Editor\General\Code Completion\Automatic Code Completion, Automatic Dot Lookup) are enabled. Is lRec1 of a record or object type?

Regards,
Roman


#3

Hi Michael,

  1. There’s no preference to turn off this feature but we have a CR to implement it for a later version

  2. The dot-lookup is still there. However, we’re aware that in some environments it is not as responsive as 5.5. Have you tried using Ctrl+space to manually fire up the dot look-up? When you do this, please take a look at the top right corner and see if the x button used to close the code editor is greyed out or not.

Gwen


#4

Roman, thanks for your clarification.

  • yes, lRec1 is an instance of Oracle object (type).

#5

Thanks Gwen.
I’ve just honestly tried Ctrl+Space - does not work - no reaction at all.
What I did: I typed lRec1 (being inside of Code Editor having my package loaded)
which is declared as
lRec1 ora_Type := ora_Type (NULL, NULL, …NULL);


#6

Hi Michael,

Thanks for the information you provided, I managed to reproduce the issue in our environment. I will log a request to fix this bug.

Gwen