Toad World® Forums

No valid Oracle Client found. Please note that TOAD only supports 32 bit Oracle Client 'nstallat'ons.Please view the release notes for additional system requirements


#1

Hi,

I get an error such as the following could be the reason for this?

My Database : Oracle 11g Release 2

My TOAD version : Toad Version for Oracle 10g

My Operating System : Windows 7 Ultimate 64 bit

Please Help

Error : http://o1306.hizliresim.com/1b/y/ps1gt.png


#2

support.quest.com/…/SOL71545


#3

support.quest.com/…/71545


#4

You are confused about the Toad versions. There is no such thing as My TOAD version : Toad Version for Oracle 10g. Toad has version numbers totally unrelated to Oracle version numbers. So there is Toad 9.6, 10.0, 10.1, 10.5, 10.6, 11.0, 11.5, 11.6, 12.0 and 12.1. So do a help about in Toad and see what version you are running. It sounds like you have an old version of toad - maybe 10.X (again - no relation to oracle 10g). Toad did not offer 64-bit support until Toad 11.6. So if you are on old version of toad you must use 32-bit oracle client - regardless of your windows bit size. Read this blog:

www.toadworld.com/…/running-toad-for-oracle-in-a-64-bit-environment-updated.aspx

Now assuming you have the right oracle client downloaded and ready to install - such as oracle instant client for 11g, you need to read the oracle install guide. For example if you use an Oracle instant client then YOU must define some windows environment variables to make it visible to apps (PATH and TNSADMIN), or apps like toad will not see your client. It sounds to me like this may be your probem - not a toad issue or bug - but an improper oracle client install/config (or wrong bit size) …