Toad World® Forums

Not able to launch the toad DevOps toolkit


#1

Hello,

We are trying to make a devops process for our database and i found that the toad devops toolkit can help us acheive our aim but i still not able to evaluate it

i follow the steps described on the below link in order to install this product, but i still not able to run it ( nothing happens when I click on the executable )

https://community.toadworld.com/products/toad-devops-toolkit/b/blog/archive/2018/01/05/installing-and-configuring-toad-devops-toolkit

Do you have any idea about this problem?


#2

Hello,

Is it the installer exe you are unable to run? Have you tried running as Administrator?

Regards,

John


#3

i’m trying to run the executable “tdt.exe” with Administration privilege


#4

Hello,

Toad DevOps Toolkit is not a desktop application (like Toad) and does not have it’s own user interface. It is designed to be used as an extension to a build automaton process (like Jenkins or Bamboo) and be called via a script (like PowerShell or VBA).

There are some videos on the Toad DevOps Toolkit community (Media tab) which help explain how it is used.

The latest version of Toad DevOps Toolkit can also be used via a Jenkins plugin (Media tab) which enables you to define additional build steps in Jenkins web console without having to use scripts.

Regards,

John


#5

In addition to what John mentioned, you can also look at the Help, which has some quick get started notes and the API documentation. I would also recommend looking at the ‘Examples’ folder to see how the different commands and calls can be made.

Also, if you are going to be using powershell as the calling source, here is a link to a step-by-step guide on how to get started with that: https://community.toadworld.com/products/toad-devops-toolkit/b/blog/archive/2017/12/06/toad-devops-toolkit-and-powershell-step-by-step