Toad World® Forums

Not enough memory to load data-- ??

Hi, All.

I ran a query that returned 1,239,297 records. When I click on the Pivot tab, I receive the error message below.

The machine is running Win7/64b; i7; 20gb RAM.

Any thoughts?

System.Exception
Not enough memory to load data.

System.OutOfMemoryException
Exception of type ‘System.OutOfMemoryException’ was thrown.
Stack Trace:
at System.IO.BinaryReader.ReadBytes(Int32 count)
at Quest.FastData.FastStringSerialize.Deserialize(BinaryReader inStream)
at Quest.FastData.FastTable.DeserializeRow(BinaryReader reader)
at Quest.FastData.FastTable.RowCollection.TemporaryDeserialize(Chunk chunk)
at Quest.FastData.FastTable.RowCollection.DeserializeChunk(Chunk chunk)
at Quest.FastData.FastTable.RowCollection.RowCollectionEnumerator.get_Current()
at Quest.FastData.FastTable.GetDataTable(IFastConversion conversion, IFastTask& task, FastDataTaskStartedHandled started, Func`3 filterPredicate)
at Quest.FastData.FastTable.GetDataTable(IFastConversion conversion)
at Quest.Toad.PivotGrid.ToadPivotGridControl.AnalyzeData(IDataSourceControl grid)

We did some work in this area of the pivot grid. Can you download the latest TDP Beta and try it there? It is version 3.4.0.1773

I tried installing 3.4 Beta, but no luck with the installation process.

After clicking on the install file, and selecting the install setting, the install activity stopped.

I tried installing it on a PC with no Toad product, but got an RC=0 error and the installer closed.

A service request was created for this issue.

To TDP_OWL:

I’m in charge of managing the installers. I humbly apologize for the error issues. The RC=0 error typically appears when the correct .NET requirements are not met on the machine.

I noticed that your operating system is Windows 7 64-bit. Operating systems Vista SP2 and newer require the .NET 4.5 Framework. Installing the .NET 4.5 Framework should allow you to install successfully.

Workaround
To work around your issue, please install the .NET 4.5 Framework on your machine then try to run the installer once more. The .NET 4.5 framework can be downloaded at the official Microsoft Website here: http://www.microsoft.com/en-us/download/details.aspx?id=30653.

If it still d****oesn’t work
If the issue still appears after installing .NET 4.5 installation, I would appreciate if you can follow these steps to provide me some information to further diagnose this issue:

  1. Open the command prompt and navigate to the installer folder location. (The fastest way is to hold SHIFT+ RIGHT-CLICK -> “Open Command Window Here” on an empty space in the window)
    OpenCommandWindowHere.png
  2. Type out: [*FileName of installer] LV [Directory to save the installer log and the installer log name].
    commandLine.png
  3. Go through the installation as you normally do.
  4. Copy and paste the contents of the generated log file back on this thread. Also add in the thread which beta installer you used (32-bit or 64-bit?).
    Thank you for your time.

We posted a new Beta that fixed this issue.