Toad World® Forums

"ORA-12154: TNS could not resolve the connect identifier" when trying to connect to Oracle database

Hi!

When I try to connect to an Oracle database I get this error message: “ORA-12154: TNS could not resolve the connect identifier” when using TNS

I am connection to other Oracle database with no problems.

I get the same error message in PL/SQL Developer.

In Oracle SQL Developer however I have no problems.

Anyone have suggestions on how to resolve this?

Arne

Check your settings for the connection in Oracle’s SQL Developer and compare them to the contents of your tnsnames.ora file - IIRC, SQL Developer uses a JDBC driver that bypasses tnsnames.ora, while both TDP and PL/SQL Developer will look to use the configuration located in tnsnames.ora.

Thanks! :slight_smile:

Have you tried creating an environment varibale > TNS_ADMIN then paste the path of your TNS file. This location can be a shared drive with mutliple users accessing it making it easy to update for all users.