Toad World® Forums

Printing data models on HP DesignJet plotter


#1

I’m trying to print our data warehouse model on an HP Designjet 500 plotter but each time I try to print I get a message stating the printer is not valid. It’s definitely on our network as I can print Visio diagrams on it. Anyone have any clue?


#2

Hi Glenn,

In the past there were problems with printing on plotter but it was the page format settings that were the main problem. Printing on plotter itself proceeded successfully. The problem with the page format settings was fixed in Beta 3.5.2.10.
Select File | Page Format, select your printer. In the Page combo-box you can see then:

  • Formats that the selected printer supports (enabled items)
  • Other formats (greyed items)

If the size you need is not offered, please select the Custom item and define the size.

Important: Before you print your ERD, we do recommend to turn off all the graphical options on the WS (gradient effect, graphical display of keys etc.)

We suggest to wait until Beta 3.5.5.5 is released (will be launched tomorrow) and try it out there. We did some significant improvements in the speed of print performance in this Beta.

So, please download the new beta when it’s available and try it again. Please let us know the result then. Thanks.

Regards,

Vladka


#3

I’m having the same problem in 3.4.16.7.

What happens if something’s screwed-up with 3.5 beta? Does it install overtop 3.4?


#4

Hello,

Yes, this was fixed in Beta 3.5.
Beta v. and full v. can be both installed on one PC, each of them have different config and other files. Once you open and resave a model in Beta 3.5, we do not recommend it to open it in lower version 3.4. So, now you can either use Beta and keep using it till the next commercial v. 3.5 is released, or wait for the commercial release.
TDM Commercial v. 3.5 is planned to be launched in approx. three weeks.

Regards,

Vladka


#5

That worked, I think.

After installing the beta and loading my model, I needed to set the “PAGE” settings before printing. I didn’t see a 42" selection, and admit I’m confused about what the other dimension might be since it’s on a roll.

In the end I selected 1mtr x 1.5 mtr.

The model printed more as I expected. But after the entities were done the plotter kept spitting paper. Not knowing when it would stop I pressed its “cancel” key so I wouldn’t empty the roll.

As far as what’s printed, if I use “BEST” quality, the left edge of entities and the relationship lines are invisible.

Other than those two items (missing lines and scrolling paper) I was much pleased, as were other on my team when I brought them the printout.


#6

Hi,

Thanks for letting us know the result.

After installing the beta and loading my model, I needed to set the “PAGE” settings before printing. I didn’t see a 42" selection, and admit I’m confused about what the other dimension might be since it’s on a roll.

To set up unit of length, please select Settings | Options | General | Unit of Length - options: millimeter and inch.
When you set up the size on the Page Format dialog, select ‘Custom’ in the Scale Page box and enter the sizes manually.

As far as what’s printed, if I use “BEST” quality, the left edge of entities and the relationship lines are invisible.

Thanks for the info. We will check it out.

Thanks again.

Regards,

Vladka + TDM Team


#7

A quick comment on this.

It turns out that printing to plotters is very finicky. I must have stumbled across the magic combination of page sizes and other features to get it to work. More often than not, I’m always given an error about the print range being outside the page borders, or something like that.

Next time it happens I’ll try to pay more attention.