Toad World® Forums

Problem when I schedule an automation script

When I schedule this automation script, it errors out and I get this message in the log. “Rpt_99.log: Export_1 - Could not find a part of the path ‘M:\East\05. Respite Cost Plans Per person’.”

The path and file is not associated with this script anywhere.

Here is a copy of the log file.

– 7/25/2016 5:00:06 AM: Rpt_99.log: Setting up environment

– 7/25/2016 5:00:06 AM: Rpt_99.log: Script run by Toad Data Point 4.0.0.613 as DD01150 on DD0119WN21996

– 7/25/2016 5:00:06 AM: Rpt_99.log: Build started

– 7/25/2016 5:00:06 AM: Rpt_99.log: Compiling script

– 7/25/2016 5:00:06 AM: Rpt_99.log: Start CompileWorkflow

– 7/25/2016 5:00:06 AM: Rpt_99.log: Before Compile

– 7/25/2016 5:00:10 AM: Rpt_99.log: Return from CompileWorkflow

– 7/25/2016 5:00:10 AM: Rpt_99.log: Workflow Compiled without Errors

– 7/25/2016 5:00:10 AM: Rpt_99.log: Build completed

– 7/25/2016 5:00:10 AM: Rpt_99.log: Create Workflow instance

– 7/25/2016 5:00:11 AM: Rpt_99.log: Started workflow instance

– 7/25/2016 5:00:11 AM: Rpt_99.log: Begin execution script activities

– 7/25/2016 5:00:11 AM: Rpt_99.log: Variable “ROOT_PATH” set to ‘’

– 7/25/2016 5:00:11 AM: Rpt_99.log: Running export template C:\TOAD Data\Template\99. Costplan Activity.txp

– 7/25/2016 5:00:12 AM: Rpt_99.log: Executing export using connection in template is not XQuery Connection

– 7/25/2016 5:00:14 AM: Rpt_99.log: Export_1 - Could not find a part of the path ‘M:\East\05. Respite Cost Plans Per person’.

– 7/25/2016 5:00:14 AM: Rpt_99.log: This file was not available at runtime. The location and user authentication may be different at runtime.

– 7/25/2016 5:00:14 AM: Rpt_99.log: Start error email

I have other scripts that are failing with the same error message.

Any ideas about what is causing this?

What is the log id used to run the scripts when scheduled? Some user run under the SYSTEM account. This account would not have privs for your mapped network drive. Check that the user id you scheduled the script to run as is able to access that directory. Mapped drives should be okay but we try to use the full network name.

Thanks for the reply, Debbie.

I use my accout as an administrator to schedule the automation.

What I don’t understand is the file it can’t find is not referenced anywhere in the script. Nor is it the list being exported to. Where could it be picking up that file?

I am exporting to a list, (99. Costplan Activity), and the file it can’t find, (‘M:\East\05. Respite Cost Plans Per person’), is an Excel document in another section of the SharePoint Site.

I can run all of the automation scripts directly from TDP with no issues. It’s only when I try to schedule them that I have problems.

Sounds like some privilege issue with Sharepoint. Are you using our connector to Share point? Or our export to Sharepoint list feature? We have many people using both of these features a lot. Most issues have to do with how Share point is set up.

I have privileges just below those of the owner.

I am using the export to sharepoint feature. The query is a cross connection query using SharePoint and Oracle.

What I don’t understand is why it is looking for a file that has nothing to do with the query or the export.

I have several other export automations that use the same structure that work.

I changed to use the full SharePoint network drive address. Then I got the error message that the “address” exceeds the 256 character limit. I had to go back to using the mapped drive letter. I am now attempting to determine why the mapped drive letter won’t work when I use the scheduler. The script runs great when I run it from TDP.

I still have not solved this issue. I have 2 scrips, that ran previously with no issues, that I have been unable to get to run using the scheduler. I have tried different methods of addressing the file it can’t find…all with no success. However, if I run these scripts from TDP instead of through the scheduler, they work perfectly. I have to run these manually every morning so it is becomming a real problem.

Bill,

When you schedule the task, under security options, did you use your own account? Did you check “Run with highest privileges” box? Could you forward me your export template and automation script to investigate if possible.

Thanks,

Yake