Toad World® Forums

problem with decimal separator


#1

One of my co-workers has a problem with the decimal separator. It keeps on
reverting to a comma.

This is Toad 10.1

We go into options and change it to a period. But the minute we do an F5 or
execute via SQL*Plus it reverts back to a comma.


#2

Erwin,

F5 obeys the NLS_NUMERIC_CHARACTERS setting so if he wants to change it, he
needs to run an alter session. If he has Options -> Oracle -> Transactions ->
Execute scripts in Toad session checked, it will stick for subsequent scripts.

SQL> alter session set NLS_NUMERIC_CHARACTERS = ',.'
Session altered.
SQL> select (1/2) from dual

(1/2)
----------
,5
1 row selected.
SQL> alter session set NLS_NUMERIC_CHARACTERS = ‘.,’
Session altered.
SQL> select (1/2) from dual

(1/2)
----------
.5
1 row selected.


#3

How do I unset her NLS_NUMERIC_CHARACTERS so it is permanent. She is the only
one where the NLS_NUMERIC_characters are wrong.


#4

Pretty sure that’s in the registry Erwin


#5

You may want to check if she has something in the login/glogin scripts that’s
setting that might be changing the values. Also, is she using the same NLS_LANG
as everyone else?


#6

Thank you. I am asking her to see a DBA to check into all that info.


#7

Thank you. I am asking her to see a DBA to check into all that info.

This couldn’t be a Regional and Language Options setting in Winders (that’s
where it is in XP anyway), could it? IIRC, that’s used for date formats in
Toad.

Just a thought…

Rich – [TeamT]

Disclaimer: I make my own ash clouds, thank you very much.


#8

She told me today that she had used her Toad 9 to do something and when she opened Toad 10 afterwards the coma/period problem seemed to be solved.