Toad World® Forums

problem with snapshot compare

I am using TOAD for DB2(z/os) and i have been getting an error when i compare a schema against offline snapshot. To experiment with this feature, i created a temp table took a snapshot and dropped the table and wanted to compare.

i have posted the error below. Has anyone else recieved a similar error?

Thanks!

Index was outside the bounds of the array.


Level 1 inner exception (Quest.Compare.Schema.Common.Pl.CNSLoader+ModelThreadException):
Index was outside the bounds of the array.
Call Stack:
at Quest.Compare.Schema.DB2.DBModel.CNS2Loader.FillModel(CNSPLProgress plProgress, LimitationParms dictLimitations, ICNSNode iNode1, ICNSNode iNode2)
at Quest.Compare.Schema.DB2.DBModel.CNS2Loader.FillNodes(CNSPLProgress plProgress, IEnumerable1 idList1, IEnumerable1 idList2, ICNSRootManager rm)
at Quest.Compare.Schema.DB2.DBModel.CNS2RootManager.LoadModelForSchemaCompare(ICommandProgress progress, Boolean needReferences)
at Quest.Compare.Schema.Common.Pl.CNSCmdFillPairTree.CommandExecution(ICommandQueue icmdqueue)
at Quest.Compare.General.Sys.ProgressiveCommand.ExecuteCommand(ICommandQueue icmdqueue)


Level 2 inner exception (System.IndexOutOfRangeException):
Index was outside the bounds of the array.
Call Stack:
at Quest.Compare.Schema.Common.Pl.CNSDataReaderBase.Fields.SetField(Field oField)
at Quest.Compare.Schema.Common.Pl.CNSDataReaderBase.Fields.Read(BinaryReader br)
at Quest.Compare.Schema.Common.Pl.CNSDataFileReader.Init(BinaryReader brSnap, Boolean bReaderPassedFromOutside)
at Quest.Compare.Schema.Common.Pl.CNSDataFileReader…ctor(BinaryReader brSnap)
at Quest.Compare.Schema.DB2.DBModel.CNS2Loader.DirectExtract(CNS2Database oDb, CNSPLProgress plProgress, LimitationsPack packLimitations, DirectExtractOption indOptions, String sSnap)
at Quest.Compare.Schema.DB2.DBModel.CNS2Loader.Fill(CNS2Database oDatabase, CNSPLProgress plProgress, LimitationsPack packLimitations)
at Quest.Compare.Schema.DB2.DBModel.CNS2Loader.Fill(ICNSNode iNode, CNSPLProgress plProgress, LimitationsPack idictLimitations)
at Quest.Compare.Schema.DB2.DBModel.CNS2Loader.FillInAnotherThread(Object oFillingThreadParms)

Please let us know what version of Toad DB2 you are using.
thanks

TOAD for DB2 5.0.3.718 z/os professional with DBA add-on

I have not been able to recreate this.
When you created your temp table, was that the only object that was qualified by that schema when you took the snapshot?

It might make sense to open a support case at support.quest.com so all pertinent information can be captured and tracked…

Hi,
We did some changes\fixes recently which maybe related to your issue.
Please, verify how it will be working in the next beta.
Thanks,
Vlas

I’m still getting this error when I tried to do a snapshot compare in TOAD for DB2 5.1.0.452 Beta version.

Next beta was not posted yet

Hi,
You can verify this problem using just posted beta build #493

Snapshot Compare still doesn’t work in the latest beta version (5.1.0.493). This is what i did: Took a snapshot of a schema(.DB2snp file), made some changes and compared the snapshot with the most current schema. I get an error, “Porcess Terminated due to errors…”

Please, send me your snapshot.