Toad World® Forums

Quotes in SQL Preview on Entity Properties

I just converted my data model to Postgres 11. With Postgres 10, the SQL in the SQL Preview tab of the Entity Properties form show quotes around all of the columns. With Postgres 10, there were no quotes. Is there an option that would let me hide the quotation marks? None of my column names have embedded spaces. Thank you.

Hi Tom,
go to DDL Script Generation dialog (press F9 or from main menu) . On the tab "Detail Settings" is first checkbox "Use Quotation Marks". Uncheck this and press button Generate (by press generate settings will be saved). After this you should see in SQL Preview attributes without quotations. SQL Preview is determined by settings in the Generator dialog.
Daril