Toad World® Forums

Repairt TableSpace

Hello,

Has anyone ever tried repair a table space inside TOAD for DB2 z./OS?

Command running:

REPAIR
SET TABLESPACE [Database Name].[TableSpace Name] NORCVRPEND#

Error MessagE:

DSNU180I %[Database Name] 062 09:29:51.47 DSNUGUCC - UTILITY IS NOT COMPATIBLE WITH THE LOAD UTILITUTILID = [utility id ID], OBJECT = [Database Name].[TableSpace Name]

Using Toad for DB2 6.2.0.315.

I am just trying to figure out how to do this so I dont have to write JCL to repair a tablespace.

Thanks for you help!

Robert

It could be that a load utility is running or stopped on that database/tablespace.

I do not believe DB2 allows a repair on a tablespace that also has a running/stopped utility process.

You view running and stopped utilities in Toad on the subsystem utilities tab:

Thanks Jeff! This is valuable information.

I just have one question. I don’t seem to see the subsystem utilities tab. How do you enable that to view it? I actually don’t see any of those tabs you have in your screen shot. I am thinking I don’t have something enabled to view them.

You will need a DB2 DB-admin add-on license to view the Utilities tab.

Perhaps contact your Toad DB2 sales person to get a trial with such license.

Or you can check out the Toad DB2 6.3 beta which has those features enabled.

Great! Looks like I will be installing the beta version tomorrow. I was reading the release notes and you guys added a suggestion I had last year. That is pretty sweet!! You guys rock. Keep up the good work.

I think the command works now with Beta version! Thanks again.