Toad World® Forums

Reverse engineering views-only Oracle Schema returns nothing

I /really/ need to create a model of a People Soft Oracle Schema that contains only views.

After going through the wizard and telling it not to RE entities but everything else, the resultant model has /nothing/. It does have all the users listed, including the one I’m trying to RE, but no views show up.

Does anyone know what the trick is to REing views inside an Oracle Schema’s Users?

It looks like the answer is to:

  1. create an empty (new) physical model
  2. from the file->connection, connect to your target
  3. Use the connection dialog’s “Live RE”, select the user schema, the objects beneath it, and drag those objects onto the physical model

So, even though I’ll say the question was “answered,” I’m disappointed in the result. The views don’t include their attributes. I guess I’ll ask that as a separate question.

In the Options page of the RE wizard, you should uncheck the option “Load Objects Only from Users/Schemas of Selected Tables”. It’s the first option in the Options page. Then you should get the views to display in the result diagram.

However, currently the Views does not display attributes. It’s a enhancement request for future release.

That worked. Thank you. The RE ran much longer that way than the drag-and-drop earlier, but it still worked.

Regarding the empty views, if populating views with attributes is already a feature request, and 3.5 just came out, I don’t expect to see it implemented soon.

Even if it were, I need to find another tool to do the same thing or do it manually (36 views).

Hi,

Just a quick update on the populating views with attributes request - it will not be supported in next v. 3.6 either. We believe to support it in v. 3.7.

Thanks for your patience.

Regards,

Vladka + TDM Team

Aug 18 2015 - ?? still not supported in v 5.2.

Is this frequent customer request still “active” as a Change Request?