Schema Compare crashes

I am using Toad for SQL Server 7.2, on Windows 10. When I run Schema Compare it, crashes, unless I check on a handful of items (tables, procs). And it crashes the entire product without any error message.
Has anyone else experienced this?
Does TSS store logs anywhere?

Welcome back...

Just now ran a Schema Compare on my Toad/SQL Server 7.2 on Win10, and encountered no issues. In fact, I ran the Schema Compare wizard with multiple schema targets, and all the Compares ran OK. There is a log file placed in
C:\Users\admin\AppData\Roaming\Quest Software\Toad for SQL Server 7.2
called ExceptionTrace.log
that may be helpful.

What are the exact steps you took to get to crash point? Maybe some of us can try to reproduce?
Database version?
Anything unusual about the database or schema?

Hi Gary,

I have tried this against SQL 2014 and SQL 2019.
Toad 32-bit on Windows 10

  1. Connect to a SQL Server
  2. Select Tools / Compare / Schema Compare
  3. Select Add button
  4. Click on a server connection and select the source database.
  5. Select OK
  6. Select Add button again
  7. Select a secondary connection and select the target database.
  8. Select Next
  9. Select Add (to select objects)
  10. Select Exists column twice to sort and place "Both" at the top.
  11. Select Tables, Stored Procs and Indexes. (around 40 objects)
  12. Select OK
  13. Select Next
  14. Select "Ignores"
  15. Select Next
  16. Wizard starts comparing, then progress stops during "Loading database models to memory"
  17. App crashes
  18. Nothing is logged in ExceptionTrace.log
    2022-04-26 19_52_30-Toad for SQL Server - Schema Compare Schema Comparison_ - CDVWD99A0097_TMRODEV

@Gary.Jerep Did you get a chance to test this? I'm curious if is a problem with my company's packaging of the product, or a bug.

Hey Alan,

I did not get a chance to test this, mostly because i don't have access to anything other than a SQL Server 2008 and a 2016.

However, I'd suggest opening up a Support ticket... the Engineers have access to lots of different environments and can try to reproduce your issue: