Toad World® Forums

Setting tablespace size thresholds for Generate Schema Script

Where do I set the thresholds for Small, Medium, Large, Huge tables/tablespaces for the Generate Schema Script functionality?

The Storage Clause Options tab has only one sub-tab, Tablespaces, and that only has the options for specifying which named tablespaces the different categories map to.

I know that in the Rebuild Multiple Objects window, the Storage Clause Adjustments tab has the Extents sub-tab (in addition to the Tablespaces sub-tab) that allows you to define the thresholds for rebuilds, but that does not seem to apply to the Generate Schema functionality.

I’m on TOAD 10.6.1.3.

Thanks

Wayne

Hi Wayne,

I’m glad to hear that you are using this. This is one of those features
that sometimes makes me wonder if it’s helpful or just unnecessarily
complicates things.

Anyway, to answer your question – Go to the “Script Options”
tab first. Select “Objects with Storage” first and make sure that
the “Storage Clauses” checkbox is checked. If it is, you’ll
see a “Storage Clause Options” tab in the top row of tabs. It has
the same settings as the “Storage Clause Adjustments” in Rebuild
Multiple Objects.

-John

Ahh, I see what the problem is.

Under the “Objects with Storage” tab, in addition to having the “Storage Clauses” option checked, I also have the “Tablespaces Only” option checked. When the “Tablespaces Only” option is checked the “Extents” tab on the “Storage Clause Options” tab disappears (and it is the “Extents” tab that has the size thresholds). If I uncheck it, the Extents tab reappears.

Possibly a bug? Is there any reason that you should not be able to categorize your objects by size if you only want the TABLESPACE clause and none of the other storage clauses?

Wayne

Looks like that was fixed sometime between 10.6 and 11.5. I just tried in 11.5
and there it doesn’t matter if “Tablespaces only” is checked
or not.

Cool! Thanks!

Hopefully I’ll get a chance to upgrade soon.

Wayne