Toad World® Forums

SOLVED (thanks Dan): Unable to fetch all results when total results are over 6000 lines

Hello,

I am running into an issue that I do not know how to fix. Whenever I run a report where the results are over 6000 lines, i can fetch 1000 at a time but if i try to fetch all I get the error message below. I compared my settings with the settings of a co-worker who does not have this issue and I cannot find any differences. Does anyone know what could be causing the issue?

System.IO.DirectoryNotFoundException
Could not find a part of the path 'C:\Users\rnordingjr\AppData\Local\Temp\3\483752f9-c15a-4691-892d-e6ae8f7e2607.tmp'.
Stack Trace:
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize)
at Quest.FastData.FastTable.GetTempFileName()
at Quest.FastData.FastTable.RowCollection.SerializeRowData(Object data, FastSerialize serializers)
at Quest.FastData.FastTable.RowCollection.<>c__DisplayClass50_0.b__0(Object )

Hi Robert,
which DB is it? Can you not use our native IBM connections, do you have to use ODBC?
The error message related to IBM connection may hint at low bufferpool - can you check your settings?

Hello,

I do have to use ODBC but I am not knowledgeable enough to explain why, nobody else in my department is having issues and they all use the same database so I don't think that is the issue. My buffer pool is at 256MB

I tried setting my buffer pool to 768MB and i am still getting the same result

What have you got here?


And which IBM database is it?
Can your colleagues run the identical script without issues?

AH HA! I found the issue. My folder was set to look in a sub folder "3" under "Temp" but that doesn't exist so I removed the 3 and now it works! Thanks!

image