Toad World® Forums

Subversion configuration help

I am trying to get Subversion setup with Toad 11.

I have filled in the source control options in view - toad options - source control. I chose Subversion(SVN) from the default VCS drop down. I have filled in the settings for the SVN executable and also the server settings.

My URL for subversion looks like this. It was cleaned for security.

https://subversion_host/svn/banner/

That URL works perfectly with Tortoise SVN.

I filled in the boxes like this.

select wedav
server : subversion_host
port : 443
use ssl encryption : checked

I then go to the tool bar item “Source Control Version Control Browser”. I fill in the repository as svn/banner but I am not sure if that is correct or not.

I pass in the rest of the fields and then I get this error in the output window.

10:23:06 Error: Error logging into SVN., 10:23:06 Error: Error Opening Source Control VCS Browser: [VCS Browser Error] Error: VCS Provider is not logged in…

Thanks

Larry

Larry,

Since you can connect using http with Tortoise, it looks like this is a client
side / toad configuration issue, Probably the easiest way to track this down is
to turn on VCP Debugging in Toad. This is not available in Options (I am adding
to the beta) , but you can turn on by adding this line in the settings section
of Toad.ini

[Settings]

vcpDebug=1

You can access the Toad.ini from Options-General-Application Data Directory.
Open folder and Toad.ini is in User Files directory. Be careful not to modify
any other settings J

Run Toad and try to Log in again.

This will create a file called VCPDebug.txt also in the User Files directory. If
you could send me this file and SVN.INI also in the same directory, I can take a
look at your configuration.

My email is Stephen.Beausang@Quest.com

Thanks

Stephen

You are going to love this. I shutdown toad. I then added the new line to the toad.ini file as well as modified the svn.ini file by removing the 3 stored logins that were there. When I restarted toad I was able to click on “Source Control Version Control Browser” and fill in the needed fields and all worked fine.

When I try to add a file or commit a file I get error like this in the vcpdebug.log.

==================================================================
Timestamp: 10/4/2011 5:44:22 PM
Request: “C:\Program Files (x86)\Subversion\bin\svn.exe” add C:\Users\gutmanl\projects\TOAD_working_directory\database\test.sql
Response:
svn: ‘C:\Users\gutmanl\projects\TOAD_working_directory\database’ is not a working copy

==================================================================

Any ideas.

Thanks

Larry

HI,
I’m getting very similar problems in Toad 11.
I get the VCS Provider is not logged in when I try and select a project.

I’ve switched on vcpDebug, but there are no errors in the log, just a record of each connection attempt. I can connect using Tortoise, and also direct using http.

Any suggestions much appreciated, but am also happy to go through support as normal.

Thanks,
Ben

Ah, sorry. My bad. Toad was not pointing at my copy of svn.exe. (SVN Executable option in Options/Source Control/Subversion : settings

Can now connect to the repository - can see all folders, but no files. I’m sure this is my misunderstanding, so will continue to investigate.

Hello Ben,

This might be one for support but I would like to take a quick shot at it.
Either way it will work its way back to me J