Toad World® Forums

TDP 5.1 Query Builder Error

I'm running TDP 5.1.4.187 in workbook mode and have recently started getting the Query Builder error message below for any workbook file I try to run. When I click on "More details" nothing happens. Tried uninstalling TDP and re-installing but that didn't help.

Steve

Hi Steve,
so it happens when you try to run but not when you open it?
Do you think you could upgrade to 5.2?

Hi Dan, yes I get the error when I try to run it. When I open it the execute to SQL button is disabled so I execute the entire workbook and the error occurs. We’re having a connection issue with 5.2 that hasn’t been fixed yet so we’re unable to upgrade at this time.

Also I'm the only one getting this error. We have other users running 5.1.4.187 who aren't having this issue. That's why I tried the uninstall/reinstall but that's didn't help.

Have you tried 5.2.1? It fixes some issues with switching connections with Workbook.

I’m getting this error in 5.2.1.299:

Hi Steve,
can you try this workaround for your Devart error?
Open the file called toadexe.config that is placed in your TDP installation folder and then replace the line:

<addtype="Devart.Data.Oracle.OracleNumber, Devart.Data.Oracle"/>

with:

<add type="Devart.Data.Oracle.OracleNumber, Devart.Data.Oracle, Version=9.7.734.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />

Let me know if that error goes away, please.

Dan, the workaround gets rid of the Devart error. Now when I open a query and I login with my user id and password, I see the error below. The user shown in the error is the user that typically runs this query. Then I click on the power plug icon and select the connection I already logged into and then I’m able to process the query normally. Do you know why I’m getting this error? I believe I reported this issue in the past and it was supposed to be fixed in a future release.

Thanks, Steve

image001.png

Hi Dan, any update on this issue? Should I open a support case?

Thanks, Steve

Steve, can you send us your TWF file again?

Dan, attached is a TWF file that’s getting the error.

Steve

(Attachment Recurring JE.twf is missing)

Dan, how do I send the TWF file? Tried sending it by e-mail and via the forum and neither allows a file with TWF extension.

Steve

I'm sorry but in this kind of forum you have to change the extension to pdf and then zip and attach. Thanks

File attached, I changed extension from twf to pdf.

Recurring JE.pdf (44.2 KB)

Thanks, Steve, we'll investigate

@steve.robinson Steve, where do you store the TWF file? Do you share it with other people?

We're dealing with it as QAT-16024.

Dan, the file is stored on a network share where 2 users have access as well as me in case I need to troubleshoot any issues.

Steve

Thanks—let me know if you have any further questions.