Toad World® Forums

Team Coding disabled


#1

Hi,

I am using Toad for Oracle v13 64bit. I recently created a git repo and wanted to try out version control on Toad, so I followed the online guides to basically install team coding from the ‘Team coding’ menu option. However, after installation I noticed that the ‘Team coding’ dialog now has disabled the ‘VCS provider’ option under Team Settings|General. But also it display’s ‘Read Only’ in the status bar.

Does anyone know what I need to to enable this or if I am missing any steps/files/etc?

Thanks. J


#2

The Oracle user that you used to install TC was granted “Default” for your TC Admin roll, but you have to log off and log back in with that user for it to take effect. Please try to logoff then log back in to with this user. If this doesn’t do it, login as sys and grant TC_ADMIN_ROLE as default to your user and try again.

From: j.ramjee bounce-jramjee@toadworld.com

Sent: Tuesday, May 08, 2018 8:38 AM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] Team Coding disabled

Team Coding disabled

Thread created by j.ramjee

Hi,

I am using Toad for Oracle v13 64bit. I recently created a git repo and wanted to try out version control on Toad, so I followed the online guides to basically install team coding from the ‘Team coding’ menu option. However, after installation I noticed that the ‘Team coding’ dialog now has disabled the ‘VCS provider’ option under Team Settings|General. But also it display’s ‘Read Only’ in the status bar.

Does anyone know what I need to to enable this or if I am missing any steps/files/etc?

Thanks. J

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle Forum
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#3

Hi Brad,

Thank you for your email.

I am trying this out using Oracle XE database before attempting any changes on our corporate databases.

I logged in using the TC_ADMIN_ROLE and this hasn’t worked.

Can you please explain how to “grant TC_ADMIN_ROLE as default to your user ”?, as I tried the following after logging out and back in but no change:

alter user SYS default role TC_ADMIN_ROLE;

Thanks, Jay

From: Brad Boddicker [mailto:bounce-ButtonPusher@toadworld.com]

Sent: 08 May 2018 15:28

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Team Coding disabled

RE: Team Coding disabled

Reply by Brad Boddicker

The Oracle user that you used to install TC was granted “Default” for your TC Admin roll, but you have to log off and log back in with that user for it to take effect. Please try to logoff then log back in to with this user. If this doesn’t do it, login as sys and grant TC_ADMIN_ROLE as default to your user and try again.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle Forum
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#4

Don’t use the sys schema to administer TC. Grant that role as default role to another user, preferably a DBA user, and use that user to administer.

From: j.ramjee bounce-jramjee@toadworld.com

Sent: Tuesday, May 08, 2018 11:31 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Team Coding disabled

RE: Team Coding disabled

Reply by j.ramjee

Hi Brad,

Thank you for your email.

I am trying this out using Oracle XE database before attempting any changes on our corporate databases.

I logged in using the TC_ADMIN_ROLE and this hasn’t worked.

Can you please explain how to “grant TC_ADMIN_ROLE as default to your user ”?, as I tried the following after logging out and back in but no change:

alter user SYS default role TC_ADMIN_ROLE;

Thanks, Jay

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle Forum
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.