Toad World® Forums

TNS timeouts logged on server overnight (12535 12170 12560)

Hi,

We’re getting a bunch of TNS timeouts logged in our server’s alert log that
appear to be caused by Toad for Oracle Base v10.6.1.3 sessions.

e.g.,
Fatal NI connect error 12170.

VERSION INFORMATION:
TNS for Linux: Version 11.2.0.1.0 - Production
Oracle Bequeath NT Protocol Adapter for Linux: Version 11.2.0.1.0 - Production
TCP/IP NT Protocol Adapter for Linux: Version 11.2.0.1.0 - Production
Time: 04-OCT-2011 19:13:10
Tracing not turned on.
Tns error struct:
ns main err code: 12535

TNS-12535: TNS:operation timed out
ns secondary err code: 12560
nt main err code: 505

TNS-00505: Operation timed out
nt secondary err code: 110
nt OS err code: 0
Client address: (ADDRESS=(PROTOCOL=tcp)(HOST=whatever)(PORT=whatever))

Can anyone suggest where I can either

  1. disable the timeout (developers on the test machine leaving sessions overnight)
    or
  2. disable these errors from cluttering up the alert log?

Thanks in advance,

Frank

No-one?

Sigh.

  1. Let the developers close there Toad sessions? Is there a reason to let them
    open? You can define a job where all Toad sessions are closed in the night if
    they are not listening, but noone would be glad with that.

  2. Those type of messages goes to the alert log. No choice there.

Groetjes,
Wim

2011/10/11 Frank Bell

Message from: FrankB

No-one? Sigh.

_______________________________________

Historical Messages

Author: Frank Bell
Date: Tue Oct 11 02:22:32 PDT 2011
No-one? Sigh.
__

Author: Frank Bell
Date: Wed Oct 05 03:02:10 PDT 2011
Hi, We're getting a bunch of TNS timeouts logged in our server's
alert log that appear to be caused by Toad for Oracle Base v10.6.1.3
sessions. e.g., Fatal NI connect error 12170. VERSION INFORMATION: TNS for
Linux: Version 11.2.0.1.0 - Production Oracle Bequeath NT Protocol Adapter
for Linux: Version 11.2.0.1.0 - Production TCP/IP NT Protocol Adapter for
Linux: Version 11.2.0.1.0 - Production Time: 04-OCT-2011 19:13:10 Tracing
not turned on. Tns error struct: ns main err code: 12535 TNS-12535:
TNS:operation timed out ns secondary err code: 12560 nt main err code: 505
TNS-00505: Operation timed out nt secondary err code: 110 nt OS err code: 0
Client address: (ADDRESS=(PROTOCOL=tcp)(HOST=whatever)(PORT=whatever)) Can
anyone suggest where I can either 1) disable the timeout (developers on the
test machine leaving sessions overnight) or 2) disable these errors from
cluttering up the alert log? Thanks in advance, Frank
__
_______________________________________

Is this through VPN?

Sounds to me like one of two scenarios. Either your DBA has created a profile
with a disconnect after N minutes of inactivity or the sqlnet.ora files on
client machines and/or server has been set to timeout. So when database says
goodbye to toad it’s not toad’s fault – so this is a database
issue.

Hegyvari Kriszt…:
They are on the LAN, not via VPN but thanks anyway.

wimdelange_062:
The reason why they leave them all night is to avoid having to open
up the various sessions (multiple schemas on dev & test systems)
and cached queries (yes, they could use notepad instead!).
This wasn’t a problem with Toad in the past but I don’t have the
version number to quote on that (+ they were also on XP vs Win7).

Thanks for confirming that I can’t block/redirect the messages
away from the alert log though … I wasn’t sure if there was
some trick with an event that I could have used. :frowning:

bscalzo:
Have checked the databases involved and none have profiles that
define either idle_time or connect_time limits.
Have also checked the sqlnet.ora files on the servers and on
a few of the affected client PCs and found nothing of interest.

Ah well, thanks to all of you for trying to help … if anyone comes up
with further ideas in the future, please post them as I’ll check back
every now & then - just in case.

Cheers,

Frank

Have you checked your Windows 7 advanced power settings? It’s possible that M$
is turning off your network card to save energy.

The reason why they leave them all night is to avoid having to open up the
various sessions (multiple schemas on dev & test systems) and cached queries
(yes, they could use notepad instead!).

Introduced in Toad 11 (perhaps 10.6) is an option to leave the Editor open when
a session ends. Options|Editor|Behavior|“Close Editor when session ends”

That’ll allow you to close down sessions and keep scratch pad work. There are
also two ideas in the IdeaPond that may interest you. Vote for them if you like.

http://toadfororacle.ideascale.com/a/dtd/Save-All-SE-tabs-as-a-single-file/46060-
8477

http://toadfororacle.ideascale.com/a/dtd/Save-All-Tabs/115366-8477

Michael

… and that seems to be the cause - thank you!

I’d gone back to check the apparent correlation between the newer
TOAD version & the problem and found that it was also an equal
correlation between Windows 7 & the problem so started to look
elsewhere and behold, your suggestion was exactly right.

Thanks again to everyone for their help.