Toad World® Forums

Toad 4.1 Automation Randomly Hanging

Recently, I have noticed that my automation scripts randomly hang. The scripts that are hanging are newly created in TDP 4.1 or updated to 4.1 version. Scripts created in 3.7 run fine without any issues, and these scripts were not updated to version 4.1. Updating to 4.1 means that I opened the TAS file in TDP 4.1 and saved the changes. I have three automation script setup which run at 2 AM, 6 PM, 11 PM, and hourly from 8 AM - 5PM, and each have nested scripts. I have not been able to consistently replicate this issue. Has anyone experienced or observed automation scripts hanging?

I have that now and then as well. I have to go to the task to kill it and then rerun and it usually runs fine.

It’s extremely difficult to watch these as they happen and try to get the information needed to help troubleshoot. If you are able to get more information or catch them before I can, I’m up for anyone trying to continue to troubleshoot the issue. I’m sure they will need log files, support bundle, what connections you are using, etc. to help with the initial troubleshooting. I know that’s what I started with. Maybe some of your info can help shed some light further on this issue.

Glad to see it’s other folks that have similar issues :slight_smile:

Can you post an automation script that hung. I’d like to get an idea of what it was working on and what kind of connection was involved.

Debbie: I submitted a support ticket for this issue (3885342) and provided the files.

I see the support case. The support person has not forwarded to me yet. What I need and don't see in the attachments are log files which represent the hanging. I need to get some bead on where the hang tends to occur.

Also, your description infers that the issue is with newly created TDP 4.1 scripts. I don't suspect the scripts themselves, rather TDP 4.1 that is running the scripts. It is possible to have an older version of TDP run the newer scripts as long as they don't use newly introduced features of automation, which there weren't any in 4.1 If you want to try this, go to the task scheduler in TDP 3.8 and press the "migrate" button. See attached. This will take selected scheduled activities and run this with the version of TDP you reset them with.

This will not help debug things but might keep any production scripts more stable. I would still get a script that often hangs and put on verbose logging. When it hangs get a copy of the automation script and give to support. By default this files are in path below (just edit to your profile name)

You could also run a script daily to zip up all the files in the directory and email to you. Then you have the log files when something hangs.

C:\Users\dpeabody\AppData\Roaming\Quest Software\Toad Data Point 4.1\Automation

Debbie: I created a simple automation script to run hourly. When the crash occurs, I will send the files via the support tickets.

Also, when the crash happens and you see Toad.exe still in the processes list, can you right click on it and generate dump file? It will be rather big. We can figure out how to get to me when you have it.,

Debbie: I have the files ready for upload. I tried via the support site but nothing was uploaded.

The last version I used prior to 4.1 was 3.7. So, I installed 3.7 and opened a TAS file. This is the message I get:

Debbie, I got the case and opened an FTP site to upload the dump file. Keep you posted via subcase as need it.