Toad World® Forums

Toad Data Point 3.5 using bind variables in import wizard - Error importing data, object reference not set to an instance of an object


#1

I set up an automation script with a set variables activity and an import activity. The import wizard reads a sql query with a bind variable. I am using a sql server connection as the target database and IBM DB2 iSeries connection for the source data. When I run the import I get an error message that says Error importing data, object reference not set to an instance of an object. Additionally, if I try to set up more than 1 query within the import wizard, I get this error when tryin to save the import template. If I only set up 1 query, I am able to go through the wizard, but then I get the error when I go to run the script. I didn’t see any reference to iSeries connections and not being able to use a bind variable in an import wizard. The wizard seems to work fine with a variable and sql server to sql server connections.

Can anyone recreate this with an iSeries connection?


#2

Seems like this is iSeries-specific issue again. We’ll investigate this.

Igor.


#3

Can we get a copy of the automation script, import template and the automation log file? It will be easier to investigate with these files.


#4

Debbie - I managed to get something to work by doing a combination of things.

So, first I set up the query with : before the variable.

I set up the import template within the automation script.

Then I changed the variables to [tag:variable]# instead of :variable.

This time when I ran the script it worked and imported my update records into my sql server staging table. But, if I try to edit the import script I get an error again, and I have to change ## to : in order to access the import template. I’ll attach the files.


#5

Can I send you the files in an email?


#6

Yes. Send to debbie.peabody@quest.com. Include automation script, any dependent files and the last automation log file that shows the error.