Toad World® Forums

Toad Edge CLI support user password?


#1

I am learning to use CLI and am having trouble in executing CLI commands with user password. The command output I am getting is below:

C:\Program Files\Quest Software\Toad Edge\CLI>java -jar toadedge.jar -snapshot -in “.\connection\BSFAurora_localhost.xml” -out “.\snapshot\BSFAurora_localhost.json”
2018-06-21 16:29:41,272 INFO : Command: snapshot
2018-06-21 16:29:41,274 INFO : Loading source input
2018-06-21 16:29:41,854 ERROR: java.sql.SQLException: Access denied for user ‘root’@‘localhost’ (using password: NO)
com.quest.toad.execution.ExecutionException: java.sql.SQLException: Access denied for user ‘root’@‘localhost’ (using password: NO)
at com.quest.toad.execution.executor.SqlExecutor.getConnection(SqlExecutor.java:309)
at com.quest.toad.mysql.core.sql.MySqlExecutor.createConnection(MySqlExecutor.java:109)

In my connection XML file I’ve specified:

root

true

mypw

If I clear out the root user password in the database it will run successfully regardless whether the value is true or false.

Is this known issue?


#2

Hello Eugene,

I tried to create a Snapshot of a MySQL 5.7 database, using a connection with a password, and I didn’t run into a problem, so I will have to ask for some information.

  1. First a foremost - the example .xml file you have provided - is that a file you have created yourself, or was it generated by Toad Edge CICD Wizard? The reason I am asking is because TE encrypts exported passwords, and yours is not encrypted. Also, I do not have a property in my connection file.

  2. What version of Toad Edge are you using?

  3. What version of database are you using? Is it normal MySQL distribution, or something else?

Best Regards,

Tomáš Pustka


#3

Tomas, Thanks for the quick response. This answers my question. After I changed to use CICD Wizard generated connect file I am able to generate snapshot on local database.

But I still cannot generate snapshot on a remote server. I will post the question in another thread.

Thanks, Eugene


#4

Tomas, I tried to use the connection XML file generated by CICD Wizard. Now it is using the encrypted password but still getting access denied.

The issue seems to be CLI is appending the localhost IP to the root user account instead of using root account on target server, as specified in connection XML, HOST tag. I can generate snapshot on localhost just fine with password.

Below are the command output and a snip of connection XML.

C:\Program Files\Quest Software\Toad Edge\CLI>java -jar toadedge.jar -snapshot -in “./connection/ETL (BSFAurora).xml” -out “./snapshot/BSFAurora_ETL.json”
2018-06-22 09:04:52,892 INFO : Command: snapshot
2018-06-22 09:04:52,894 INFO : Loading source input
2018-06-22 09:04:53,633 ERROR: java.sql.SQLException: Access denied for user ‘root’@‘192.168.50.127’ (using password: YES)
com.quest.toad.execution.ExecutionException: java.sql.SQLException: Access denied for user ‘root’@‘192.168.50.127’ (using password: YES)
at com.quest.toad.execution.executor.SqlExecutor.getConnection(SqlExecutor.java:309)
at com.quest.toad.mysql.core.sql.MySqlExecutor.createConnection(MySqlExecutor.java:109)
at com.quest.toad.execution.executor.SqlExecutor.doReconnect(SqlExecutor.java:163)

<?xml version="1.0" encoding="UTF-8"?> MYSQL ETL Dev(BSFAurora) dev-etl-sandbox.cluster-cc6qja0eindn.us-east-1.rds.amazonaws.com 3306 root true encrypted password true 2018-06-21T09:11:34 #00FF00 BSFAurora

Thanks,

Eugene


#5

Hi, just an idea,

Is not it a DNS problem?

Could you please check your hosts file and ping this address: dev-etl-sandbox.cluster-cc6qja0eindn.us-east-1.rds.amazonaws.com

run in command line this: ping dev-etl-sandbox.cluster-cc6qja0eindn.us-east-1.rds.amazonaws.com

thanks

Miroslav Stanik


#6

Miroslav, Thanks for responding. I tried the ping command and it’s not responding. But Toad Edge schema compare works fine with the AWS endpoint.

According to the error message CLI is using the wrong account thus access denied from the endpoint.

I will work with our network team to resolve DNS and see if that would fix the CLI issue.

Thanks,

Eugene


#7

Hi, there can be also issue with your root account, do you have rights for remote access for root user?

similar problem described here:

https://superuser.com/questions/603026/mysql-how-to-fix-access-denied-for-user-rootlocalhost

or

https://stackoverflow.com/questions/6239131/how-to-grant-remote-access-permissions-to-mysql-server-for-user/27644973

Are you using same JDBC driver in Toad Edge desktop and command line tool?

Are you on same machine for desktop and command line tool?

Do you have more accounts in DB just to try remote access with different account?

thanks

Miroslav Stanik