Toad World® Forums

Toad error: System.NullReferenceException at stack trace at DevExpress

Since last two days ago, what ever I do, like opening a file in Toad for DB2, or running a query, I get the following error message. I have to click on OK 3 to 4 times to get rid of it to do my work. Can anyone helpe me? Thanks

System.NullReferenceException
Object reference not set to an instance of an object.
Stack Trace:
at DevExpress.XtraTreeList.Accessibility.TreeListControlAccessible.GetAccessibleObjectById(Int32 objectId, Int32 childId)
at DevExpress.XtraTreeList.TreeList.GetAccessibilityObjectById(Int32 objectId)
at System.Windows.Forms.Control.GetAccessibilityObject(Int32 accObjId)
at System.Windows.Forms.Control.WmGetObject(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at DevExpress.XtraEditors.Container.EditorContainer.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Can you supply some additional information please:

  • what version of Toad DB2 are you running?
  • what windows do you have open in Toad (if any) when this occurs?
    (i.e the database browser, object explorer, etc)
  • if you have a database browser or object explorer opened, what view is that
    (i.e. tabbed, flattree, etc)
  • did this ever work for you without throwing an error?

thanks

Thank you for helping. My answers to your questions are:

Toad version is 4.5
the editor window when running querey
with no wondows open, when open File it happens
No matter what view I opened, it happend also with no View opened
never it worked recently without throwing an error.

I installed new version 4.7, and I don’t see the error any more. But is good to know what caused the error.

Following a memory error while scrolling down the data viewer, this error message only returns when ever I try to execute a query (any query at all) from the Query Editor when connected to the DB2 database. The problem does not happen when querying via the Oracle connection. The connection to DB2 seems to be established properly since I can look on the data viewer and scroll to the bottom of a 900,000 row table in the table and data viewer. The only time I get this error is when I want to use the Query Editor and execute anything from it. I can go to the Query Builder and pass its contents to the Query Builder and the same error happens while in a DB2 connection. If the connection was bad one would think I would be prohibited from seeing data in the viewer… but it is all there… all million rows. This did not start happening until the out of memory crash while scrolling the viewer. Again the connection to the Oracle database poses no issues while using the Query Editor in Toad For Data Analysts.
I have no solution to this problem yet.

System.NullReferenceException
Object reference not set to an instance of an object.
Stack Trace:
at Quest.Toad.Editor.EditorForm.PostChanges()
at Quest.Toad.Editor.EditorForm.DoExecuteSqlScript()
at Quest.Toad.Editor.EditorForm.ExecuteSqlScript()

Les1,
Can you also confirm what product (Toad for DB2\Toad for Data Analysts) and what version of the product you are using?

(It seems that you might be using Toad for Data Analysts per your text in the post.)

This information would be helpful in determing if indeed this has already been addressed.

Also, please provide information about your system, such as:
OS type
Amount of memory
Etc
(You can use the Help | Support Bundle toolbar to create a support bundle that will contain that information)

Thanks.