Toad World® Forums

Toad fails to execute query using SQL*Plus

All,

This relates to Toad for Oracle, Beta 12.12.0.12

When I have Toad execute a query using the “editor” --> “Execute query via SQL*Plus” that normally works flawlessly.

Unfortunately, for one specific schema it fails to do so; it does bring up a DOS-box for SQL*Plus, but then it fails:
20170817 sqlplus failure.png

So I tried to connect manually. Same result.
Realizing the password contains an @-sign, I then retried with the password enclosed in “double quotation marks”.

That worked!

So, could it be Toad is supplying the password to SQL*Plus without enclosing quotation marks?

If so, could it be fixed, please?

Kind regards,
Abe Kornelis

Abe, It’s like you’re sitting behind me watching me work. :slight_smile: I just ran into this yesterday in some things I’m doing.

Oracle has a doc on passwords… http://docs.oracle.com/database/121/DBSEG/guidelines.htm#DBSEG10005

…and Ask Tom has a post on the same… https://asktom.oracle.com/pls/apex/f?p=100:11:::NO:RP:P11_QUESTION_ID:9533940800346284735

It seems like Toad should be wrapping any password that doesn’t fit this… "can contain only alphanumeric characters from your database character set and the underscore (_), dollar sign ($), and pound sign (#)."

I’ll take a look.

Thanks,

Michael

Michael,

I’m sorry - I cannot read thoughts. (My wife regrets this, but to most this is a great relief :wink:

Anyway, for ease of coding you might opt to enclose any pwd in “” marks…

Kind regards,
Abe

This is fixed for next beta. I had considered just wrapping all passwords, but the routine used for generating the connect string is used elsewhere and produces strings that are user facing. Some may not take kindly to seeing unnecessary double quotes.

Michael

Agreed. Thanks for the fix.

Abe