Toad World® Forums

Toad for SAP - unable to save Image data type onto file

Hi Team,

I'm using Toad for SAP 4.0.3.30. I'm trying to see the Image data type from Table of SAP ASE 16.0. Unfortunately, I cannot save the Image file onto any .jpg file anyway, and seem like the Image file was corrupted saving it.

I found this KB. but it was a bit old (Toad for SAP 2.0 , since 2013), so I'm wondering if this bug whether fixed yet. Does this bug fixed on Toad for SAP 4.0 yet ?

Documents stored in database (as type Image) cannot be saved to a file if greater than 32K (115849)
https://support.quest.com/toad-for-sap-solutions/kb/115849/documents-stored-in-database-as-type-image-cannot-be-saved-to-a-file-if-greater-than-32k

Hi,
I just tried it in Toad for SAP Solutions 4.0.3.637 (64 bit) and uploaded a JPG of about 180 KB to SAP ASE 16 and it worked fine - both uploading and displaying.

Have you tried uploading an image on Toad for SAP 4.0? Which Toad version was used to upload the corrupted image?

Hi Dan,

I'm using Toad for SAP 4.0.3.30. My Image size around 3MB.

May be , let's I try to install the same version with you first.

Will keep you post.

Thanks,
Kittipop

Which version was the image uploaded with? TSAP 4.0.x or 2.0?

Hi Dan,

I have used the same version of TSAP 4.0.3.30 for both upload and download the Image file.

So, the TSY-164 was fixed for 2.1.
Have you tried changing the text size in Connection Properties | Options?
image

Hi Dan,

Ok. Let's me try to set "Text Size" option.

I will keep you posted.

Hi Dan,

I can manage resolve my issue by set the proper "Text Size (KB)" on the connection setting. For example, my Image size 3-5 MB., so I have set the Text Size to 10240 KB.

Thanks for you help.
Kittipop

I can display the full image now.

1 Like