Toad showing incorrect TEMP tablespace / datafile size

Product, Version, and relevant environment details:
Toad for Oracle
Oracle Database 18c Standard Edition 2 Release - Production

• Describe the problem fully. What result was expected?
Create multiple datafiles (01 -> 07):

size 16g
autoextend on next 512m maxsize 16g

TOAD menu > Database > Administer > TABLESPACES
Showing datafiles of 144 gig each
Temp tablespace total = 1008 gig

expected behaviour:
Datafiles of 16 gig each
Temp tablespace total of 7 * 16 gig.

• Can the issue be created on demand or is it intermittent?
Yes, dropped tablespace en recreated it, but the result was te same.

Thanks for the clear picture of your environment and problem.

There is some wonkiness in the data dictionary regarding temporary tablespaces in pluggable databases in 18c and 19c. I've worked around it in Toad 13.2. Please give it a try there and let me know if it's working correctly.

You can get 13.2 here. Get the same bitness (32/64) as 13.1. Don't uninstall 13.1.

We used the Toad for Oracle 13.2 Beta version and the issue is now solved. Thank you. Regards, Joost.

1 Like