Toad World® Forums

Toad SQL Query Output Format Issue

Hi,

I was doing a query thru Toad on our Oracle database. When it comes to phone number which defined as Varchar2(40), the result somehow not fully displayed in the result grid view. Only if you double click on single result the full content is displayed. May i know why and how can i get the result with full content.

Result in grid view after query:

+81463877373…

After Double Click(Real Data):

+81463877373
00000000000

R-click on the data grid, and select ‘Size Columns’, then ‘Size to Data’.

Hi,

Thanks for your feedback, however, it still shows … instead of the 0000000.

It looks like there is a line feed in your data. We just show the first line of multi-line data. If you want to see the other lines, you have to double-click it.

Thanks for you feedback John. I would think the same since if i double click, as you can see in previous thread. It indeed shows 2 line with a new line of 00000. But if i click on Single Record View which looks like a little book icon, it shows +8146387737300000000000 within one single line. So i got a little bit confused the real content in DB.

I just tested the single record viewer and saw what you describe - line feeds not showing. I’ll take a look at that.

We use what’s called a TDBEdit control to display VARCHAR2 fields in the single record viewer, and TDBEdit does not handle line feeds at all. So for the next beta, I made a change that if the VARCHAR2 field contains multiline data (only in the current row - we don’t check every row in the table), then we’ll show it in a multiline control (the same type of control that we use for CLOB fields). If you go into the options, there is a setting for how many vertical lines the control takes up.