Toad World® Forums

Unable to find an entry point named 'SQLFreeConnAttribsADONET' in DLL 'db2app64.dll'

I am using Toad Data Point 5.0.4.45 and IBM Data Server Client 9.7.400.501 (64 bit). This combination worked fine on my old workstation, but I recently got a corporate refresh and now the same configuration is giving me an error when I try to connect to DB2. The error is:

System.EntryPointNotFoundException
Unable to find an entry point named 'SQLFreeConnAttribsADONET' in DLL 'db2app64.dll'.
Stack Trace:
at IBM.Data.DB2.UnsafeNativeMethods.DB232.SQLFreeConnAttribsADONET(DB2SQLGetConnAttribsADONETParams& pParam)
at IBM.Data.DB2.ConnSettingsFromXmlConfig.Dispose(Boolean disposing)
at IBM.Data.DB2.ConnSettingsFromXmlConfig.Dispose()
at IBM.Data.DB2.DB2ConnPool.ReplaceConnectionStringParms(DB2Connection connection, String szValue, DB2ConnSettings& pSettings, DB2ConnSettingsInternal& pSettingsInternal, Boolean bAttach, Boolean pushDownStrAppended)
at IBM.Data.DB2.DB2Connection.set_ConnectionString(String value)
at IBM.Data.DB2.DB2Connection..ctor(String connectionString)
at Quest.Toad.DB2.DB2ToadConnection.CreateConnection()
at Quest.Toad.Db.Connection.AllocConnection()
at Quest.Toad.Db.Connection.Connect(Boolean notify)
at Quest.Toad.Db.Provider.BackgroundConnector.CreateBackgroundConnection()

It occurs as soon as I try to connect and forces Toad to shut down. Upgrading Toad and/or my DB2 client is difficult because I'm using a corporate laptop and I'm stuck using the installation packages they've made available to me. And like I said earlier, these same install packages worked before.

Any ideas would be greatly appreciated and earn my eternal respect and admiration. They might also help these keyboard-shaped indentations on my forehead start to heal.

I am pretty sure this is related to the DB2 Client version. Toad for DB2 and Toad Data Point (when connecting to DB2) require an IBM DB2 client of v9.7.6 or greater. I know there were issues with prior versions of that client. Try upgrading your DB2 client to a more recent version.