Toad World® Forums

Unable to reverse engineer existing MySQL table

Hello,

I'm getting below error message when I tried to reverse engineer existing MySQL table. I started getting this error only from today. I'm using TDM v7.0.0.72

Please help me to resolve this error.
Thanks !!
Rajesh

Hi Rajesh,

It would probably be best to open a support ticket with Quest support so that an engineer can review with you.

This message can come up if you're not selecting the exact database version number. Are you running MySQL v5.0? Have you used the reverse engineer feature with this database and settings before?

The error message seems to mention "MariaDB" Is this a MariaDB or MySQL database? There may be some slight differences in MariaDB causing this script to fail.

If you're still having issues, please visit support.quest.com and create a ticket.

Thanks,
Mat

Hello Mat,

Yes, I’m using MySQL 5.0, I was able to reverse engineer till last week.

As far as I know “MariaDB is a fork of the MySQL database management system”. In Toad Data Modeler I picked MySQL 5.0 in the “Select Data Source” section while configuring reverse engineering connections.

I would like to share few more details for further research:

  1. On May 12th 2021, our IT team upgraded MariaDB from 10.3 to MariaDB 10.4 on the database that I used to reverse engineer.
  2. Before May12th I was able to reverse engineer without any issue. So…I am wondering if I need to change anything in ODBC connection section. Currently in the ODBC data source administrator section I have the Platform as 64bit and Driver as “MariaDB ODBC 3.0 Driver”.
  3. After posting the error message in Toad Forums, I tried to reverse engineer by unchecking "Users" in "What To Reverse" section. So...if I uncheck ”Users” I am able to reverse engineer WITHOUT any error message.

Problem is that every time I need to uncheck users in “What To Reverse” section as mentioned in above point 3. So..trying to figure out how to resolve that "internal error" message.

Please let me know if you have any questions.

Regards,
Rajesh

Hi Rajesh,

Thanks for the details. MariaDB 10.4 is closer to MySQL 8.0, so you can try using MySQL 8.0 data source rather than MySQL 5.0 as the connector in Toad Data Modeler and see if that works better.

Unfortunately, Toad Data Modeler does not officially support MariaDB. Although MariaDB is a fork of MySQL they are not 100% the same. You can see a list of incompatibility here:

Also, you're on version 7.0 of Toad Data Modeler and the current version is 7.3, upgrading Toad may help as well, but still, MariaDB not listed as a supported database even in Toad Data Modeler 7.3.

If you're still having issues, you may also want to look into Erwin which does support MariaDB. Please reach out to Joe and he can give you more details.

Thanks,
Mat

Mat,

It's weird….I was able to reverse engineer last 3 years by using MySQL5.0, also please note we are using SQLyog as GUI tool “ SQLyog is a graphical application which can interact with MariaDB Servers ”.
SQLyog — MariaDB SkySQL documentation

  • Today after posting in Toad Forums, I tried reverse engineering from one of our QA databases. I did not get any error message while reverse engineering from the QA database. Also I did not uncheck "Users" in the "What to Reverse" section.
  • That is why I'm wondering why I am NOT able to reverse engineer from our DEV database, but I am able to do that from our QA database.

Note: Migrating data models from Toad Data Modeler to Erwin is time consuming and I’m not very sure Erwin or any other data modeling tool will have “MariaDB” as a database in the connections.

I will try again by upgrading my TDM version, could you please direct me to the latest version and steps to upgrade?

Thanks !!
Rajesh

Hi Rajesh, you can download the latest commercial version by going to http://support.quest.com and typing in Toad Data Modeler into the search bar. Then you can select download 7.3 on the right hand side.