When I connect to a database, I got EurekaLog's user event handler Error

when I tried to connect a database, I got the following error:

then the Toad app was closed automatically.

it happens on this particular database only, I am able to connect to other databases. However, I can connect to that "failure" database via SQL Developer.

I am wondering what's wrong and how to fix that.

Thank you very much!

Which Toad and Oracle versions are you using?

Toad 14.0 and Oracle 19c

it works well until this morning. I tried to delete the connection and create a new and test it, it shows success. however, when I tried to connect to it, it pops up the error, then close everything.

You may have to reset your Toad settings to get past this. Steps to do that are here.

I'm sorry I don't have any more information about this error. When you see that error message, it means that our exception logging system had an exception of its own, so there is really nothing more I can tell you. Sorry. :frowning:

If the problem persists, you may have to update to the latest version of Toad to get past this.

Thanks John.

I following the instruction to reset the settings, when it tried to restart up, I got the following error:

it doesn't seems to do any changes, I can still see the DB connections and when I tried to connect to that particular db, i got the same error.

I am wondering if there is a way to clean up EurekaLog's user event or clean up some left-over from previous exceptions?

hm. Another way to achieve this is:

  1. Make sure Toad is not running
  2. Rename c:\users\a6805\AppData\Roaming\Quest Software\Toad for Oracle to
    c:\users\a6805\AppData\Roaming\Quest Software\BACKUP Toad for Oracle

Then see if Toad can start. It should create a new "Toad for Oracle" folder. If not, there is some file permission problem either with the location mentioned above, or the install location in Program Files.

1 Like

that works! Thank you very much!

1 Like

one more question:

when I tried to copy user setting from the previous folder, I get all db connections back, however, when I tried to connect that db, I got the same error.

It seems like there are some bad data for that DB.

I am wondering if I can clean up data for that DB only?

It's hard to say. Did you copy the entire user files folder (or use the Copy User Settings feature within Toad?) If so, that would copy all files and settings. The error could be coming from one of many different files.

The "safest" way would be to copy only Connections.XML from the old User Files folder to the new (do this while Toad is not running).

If you want, you can edit Connections.XML with notepad to find and remove the entry that is causing problems (also, do this while Toad is not running)


1 Like

thank you! that will help a lot!