Toad World® Forums

Allow SQL editor execute code with '@' parameters and not ':'


#1

Everytime I want to test an SQL code with parameters, I have to DECLARE them so that the code can run with the '@' character.

Otherwise I have to rename the '@' chars to ':' colon chars to be able to run the code natively.

So please allow TOAD for SQL Server to run native SQL code with '@' parameters directly and still prompt user for the values, as if running the code with colon char parameters.

ie:


SELECT StudentName FROM tblStudents WHERE StudentID = @StudentID


#2

I think this is a setting. Go to Settings, Editor, Appllication Code. At the top there are Parameter Marker options. Does changing the : to @ fix this?


#3

Probably should have tried that first. No, doesn't work.