Toad World® Forums

Problem while compiling in Editor


#1

In all early versions you could easily translate sources in the editor that contained a & character in the comments and text constants with the “Execute / compile”.

This is no longer possible because the editor always wants to replace a parameter in the places with & -signs.

That does not work like this!

See picture
toad compile mistakes 20180803.pdf (66.6 KB)


#2

Hello Stefan,

I believe what you’re looking for is in the R-click menu in the Editor. R-click > Substitution Variable Prompting > Ignore those in comments.

Thanks,

Brad


#3

Yes, that works, but to make & characters in textstrings possible, you have to switch it off completely. So you can then no longer use any parameters.

But why change something like that, that does not make any sense and annoys the customers.

Just like other things that used to be simpler and now complicated.
So some copy and paste in table and view definition or the annoying topic Compare.


#4

So some copy and paste in table and view definition

what are you referring to here?

or the annoying topic Compare.

As I said in the other thread, I tried to reproduce this and could not. Please send some code so we can reproduce this and we’ll get it fixed. you can send it to me directly: john.dorlon@quest.com


#5

In the version before 12.0 Ctrl-C could only copy the column name in the column overview of a table or view, as one would expect.

Now a whole definition z. B.

RECHTE_EBENE 7 Y INTEGER False None 0 887 0 False

copied to the clipboard.

Why? No one can use that?


#6

This was to fix a customer issue where Toad and SQL*Plus do not handle & the same. By all rights the & should be treated as a variable and customer had a really compelling reason to support it for a CI/CD process they have. With that said, it hasn’t been supported for 20 years and just recently came up. The new behavior existed for a few hours before problems came up. I’m rolling that change back so next beta will work as it did in the past.

Michael


#7

In the version before 12.0 Ctrl-C could only copy the column name in the column overview of a table or view, as one would expect.

Try right-click the row and turn off “Row Select”. Then when you right-click and CTRL+C, you will only get the current cell.

Why? No one can use that?

It is just standard grid behavior to copy what is selected (once cell, whole row, multiple rows, multiple cells). In this case, with the true/false columns, it is maybe not so useful to copy the whole row, but in other grids, this feature is handy to copy/paste the whole row into Excel.


#8

That’s right, that’s how it works, but then you can no longer individually mark the columns but only according to the “standard” grid method, which no one understands.

Too bad that the quantum grid is not working better there.


#9

I’ve made a change in SB-Tables-Columns so that the grid defaults to Cell Select instead of Row Select.

Also SB-Views-Columns and SB-MViews-Columns.

You’re right about Copy/Paste not being very useful in row-select mode for these grids, and maybe it isn’t so obvious to turn it off to change selection style. Michael and I were just talking about the possibility of a “current row” indicator that does not make the whole row selected.