Another bug (execute on execute on new connection )


Toad for Oracle Xpert (64-bit)
Add-Ons: DB Admin Module

I have in Toad defined:

Have to have checked "Execute on new threaded query sessions" as I need to have defined:

Ok, let us go further, where this file


has content:

set role c##a1_sensitive;

Unfortunatelly i need this startup script for 99% of my work but of course some users cannot exucute they get on login errors
So when I login with such (low profile user) i get on connect:

When i say ignore all then i get Toad desktop and start to work.

As i show in previous post, there is after that obviously problem with F5 executions on such an user:

F9 works thank good.

This is obviouosly a bug conencted with this part (on login) .
I have three suggestions:

  1. can you make some redefinition when to exute on login (based on username) for example
  2. can you automatically close the tab of that opene file (it is really anoying to do so every time) and if i do not close i am wrriting by mistake into that file (only one open on desktop tab in Editor)

Hi Damir,

If you want a role to be set automatically when you connect (and for every threaded session), there is a better way. This way doesn't show the Editor tab. It just runs the SQL in the background and lets you know if it failed.

  1. Go to Options -> Oracle -> Role/Alter Session
  2. On the right, click "Add current"
  3. Choose "Role" for type and type in your role name.
  4. If you wish, you can specify wildcards in the user/database fields. So if you want to try to set this role for any user that you login in as, change user to *.

I'm not able to reproduce this problem. For me, F5 works fine.

Please turn on Spool SQL to try to determine what SQL is being run to cause the error.

Role option has o be defined for each DB connection what is not a good solution my case
When I get time I will send you toad spool ... EOW probably

You don't have to define it for every DB.

If you want it for every DB, enter * in the "User" and "Database" fields. Like this:

Great, forgot to say it is closed answer.