Apps no longer work with version 17.1. "Parameters are out of sync with SQL Text in Export Dataset"

After I upgraded to the most recent version (17.1...), non of my automation apps function. I get the following message: [ app ] Failed execution: Parameters are out of sync with SQL Text in Export Dataset. Click "Set Parameters" to update them. How do I fix this?

When you first create an export dataset action with substitution variables, Toad remembers the position of those substitution variables. We need to remember the position to perform the substitution when the action is run. If that position changes (because the SQL Text as changed), then what we've remembered is wrong, so we give that message.

If an app was working fine in 17.0, then you just updated Toad and suddenly it gives this message, my inclination is that in 17.0, the substitution variables were not getting substituted at all and you didn't know it.

Anyway, this is what it's asking you to click. It may be that all you have to do is click it and then click OK to the dialog that appears.

thanks John, but my dataset source is a sql file, not sql text, so that option doesn't appear:
I output to this file: PEDI_CoOp_Bad_Matches_%q_dt.yymmdd%.xlsx using this query in the query iterator:
SELECT TO_CHAR(sysdate,'yymmdd') yymmdd
FROM dual;

sorry John, I do have a subsequent query with a SQL text dataset:
I tried clicking the Set Paratmeters link, but still same error

I can reproduce this if there is a '&' character for substitution in the file.

The only workaround I see here is to change the export from SQL File to SQL Text. :frowning:

I'll fix this right now in beta so it will work in Monday's beta.

ok, I disabled all tasks except the query iterator and the first Export Dataset (with the Sql File as the source). the sql query itself runs to completion outside of the app. there is no '&' in the sql file

Hm, maybe there is more than one problem here then.

Can you email me your non-working exported app as well as your sql file?

What do you have here?

I don't see substitution variables in the file you sent, but Toad is checking for them and that's what's causing this. So I'm not sure what's going on there, but...

If you set it to "none" and enter some obscure character for the prefix like `, does the problem go away? When I actually had a substitution variable in my file, I could make the error go away with this trick.

Edit: Does your SQL File contain a & character in some comments at the top? That could have caused this too. Toad is currently not ignoring those as it should, but I will fix that.

Thank you John. when I changed the substition variable in options it did go away. but then i wouldn'nt be able to ivoke the substitions in other sql queries. so I checked my sql file and yes, there was an '&' in the comments. I removed that and ran the app and it ran to completion. yay!

1 Like