Toad World® Forums

Auto Replace not Working

We are upgrading from Toad 12.1.0.22 to Toad 12.8.0.49 and my auto replace no longer works when I press the period character.

I noticed that the Option -> Editor -> Auto Replace -> Activation Expression is not longer displayed, but the setting is still in my Toad.ini file. I don’t know if the setting is still being used or not.

My setting look like this:

AutoReplaceActivation=[;,:.=[]()\s]

Every other character in the expression works correctly, just not the period.

Ignoring this character from the auto replace activation is very annoying because I use auto replace with abbreviations for schema names and the period activation quickly expands the full schema name and leaves the period character which is what needs to the next character. Without the period, I have to use some other activation character, like a space, and then backspace and press the period, which is not a fluid combination of characters to quickly.

Is there any way to get the period to work again for the auto replace activation?

Could the setting have been renamed/replaced?

It’s not picking up on the old activation sequence nor is the option surfaced. I’ve logged this issue to be fixed for 12.9.

Fixed for 12.9. There are a couple of minor tweaks to the prior option. First, whitespace chars always trigger. Second, the format of the option is no longer a regex character set, just type the chars in there normally. This change is in place for the next 12.9 beta.