Toad World® Forums

Auto-Replace Stopped Working Randomly

I noticed over the last few days that the auto-replace functions have just stopped working in TDP. I am using 3.6, but please do not ask me to upgrade to 3.7 as this function worked perfectly over the last 1+ year. It is only on my Oracle language shortcuts that this function does not work. SQL Server and DB2 seem to work fine. I’ve restarted, closed / reopened, disconnect / reconnect, etc. Anyone have any ideas on what else to do?

Check you settings in Tools/Options/Editor/Auto-replace.

Don't know how those would change without you knowing it. but see what is there.

don’t forget to change the language dropdown to Oracle.

All of my templates are still there, under Oracle as well as the others. This was the first place I looked when I discovered it stopped working.

Don’t have a good answer for you but try this. Go into the auto replace settings and add or change something, then save your changes. Maybe it will rewrite the settings and fix something. Grabbing at straws here. Good luck.

i have not heard of this issue but settings sometimes get messed up. I would rename the app data dir after you close TDP and then reopen. this will reinitialize things.

Debbie, where in the app data directory can I find these settings? I recently upgraded to 3.7 and all of my auto-replace templates are wiped out. Also, none of the recommendations on this thread worked, so I’m thinking I can just manually recreate all of them, but I don’t know where they are stored.

To Tony Byrnes:

Thank you for posting in Toad World!

Modified Auto-replace templates are saved and loaded from the application data directory. The full path may look like:
C:\Users\tbyrnes\AppData\Roaming\Quest Software\Toad Data Point 3.7\Templates\CodeTemplates

Software Developer I,

  • Joshua Liong