Toad World® Forums

Automate script over citrix errors out on automation log ("Couldn't opnefile for AutomationLog. Disabling Logging. The handle is invalid")


#1

We have an “automated” script that executes multiple TXP files over citrix, when we tell the script to output the log to a local client instead of the citrix sever, it creates the log file but apparently when it tries to add/write some more it errors out making the execution of the automated script very tedious. (have to click on error “ok” about 40 times)

The automated script top portion is below. Error attached.

<ta0:DefaultDescriptionActivity ProdConnection="{x:Null}" UseProjectManager=“True” LogDir="\Client\C$\temp@UPLOADS\LOGS" SmtpPort=“25” Notes=“Script Attributes” Description=“Script Attributes” TestConnection="{x:Null}" TestRootPathValue="{x:Null}" EmbedSql=“False” Enabled=“True” RelativePath=“False” ScriptVersion=“2.61” Body="" RootPathVarName=“ROOT_PATH” ProdRootPathValue="{x:Null}" Subject=“Automation Script Error (Script_1.tas)” x:Name=“Sunday_Run_1” Mode=“Test” ScriptName=“Sunday_Run_1” ContinueOnError=“continueOnError” Authentication=“Version=1,AuthenticationMethod=None”>
ta0:DefaultDescriptionActivity.AttachmentFiles
<x:Array Type="{x:Type ta0:FileDescription}">
<ta0:FileDescription FileName="\Client\C$\temp@UPLOADS\LOGS\Sunday_Run_1.log" Description="" />

multiple_errors.jpeg


#2

I checked the file permissions on the automation log file and I gave full control to essentially everyone that was on the list. It made no difference, still get the error.


#3

I assume when you designed the script and ran it was okay, correct?

And that this log file issue occurs when you schedule it? Is this correct? If so, who is logged on when running the script when scheduled?


#4

Answers immediately below your question

I assume when you designed the script and ran it was okay, correct?

When I ran the automated script with the automation.log going to the citrix tdp server, it runs fine. The log gets created on the tdp server.

If I modify the script to output the log to my citrix client, it creates the log, inserts the first line (below) and it fails to write any more to the log and shows the error attached to my original post. The error window comes up everytime it tries to write to the log (as you can imagine, there are 20 plus lines it tries to write so I have to click OK on the error window that many times to continue on.

– 3/12/2018 1:06:17 PM: Sunday_Run_1.log: Setting up environment

And that this log file issue occurs when you schedule it? Is this correct?

No scheduling attempted at this time.


#5

[View:/cfs-file/__key/communityserver-discussions-components-files/36/server_5F00_side_5F00_log_5F00_prhi.txt:320:240][View:/cfs-file/__key/communityserver-discussions-components-files/36/client_5F00_side_5F00_log.txt:320:240]

Attached are the logs from the citrix client (my workstation) log and the server side log.

Some date removed and replaced with for security reasons.


#6

BTW the template (TXP) file is supposed to create its own log, when ran as “execute template” it creates the log (although content can be very hard to read if the exported data file is large (45 min runtime), for some reason the log file ballons up with empty spaces)

When the same TXP file is part of an “automate” job/script, the log gets created, but when the TXP completes inside the automate job, it deletes it… pretty strange behavior.


#7

We test and certify on Citrix but there are different ways to set up Citrix. i believe test where everything is running on the server. Can you open up support case and we can find out more about your configuration and assist.