Toad World® Forums

Automation Designer - Import Table Data

When I use Import Table Data Action and use ‘Save SQL statements to
file’, it works just fine.

In the before import section, I selected the ‘Truncate table’, and
it does not show up in the script.

Is there a trick to do it? Is there a workaround to insert truncate statement
into the file somehow (except for typing it manually ever time)

Leo Drobnis
Sr. Database Administrator
905-290-6496

Toll Free: 1-866-287-6629 x 6496
Leo.Drobnis@dealertrack.com
DealerTrack Canada
2700 Matheson Blvd. East

West Tower , Suite 700
Mississauga , Ontario L4W 4V9

Confidentiality Notice

This e-mail may contain confidential, proprietary information of DealerTrack
Canada, Inc. It is intended solely for the named recipient(s) listed above and
should be maintained in strictest confidence. If you are not the intended
recipient, you are hereby notified that any disclosure, copying, distribution,
or use of the information contained herein (including any reliance thereon) is
STRICTLY PROHIBITED. If you have received this e-mail in error, please
immediately notify the sender and delete this information from your computer and
destroy any related paper copies

Hi Leo,

Looks like the table is truncated and constraints and triggers enabled/disabled
when the sql statements are sent to file. This is a bug and I’ll fix it.
I’m sorry, there isn’t any workaround. If you are interested in
getting the beta, I will likely have this fixed next week.

Thanks,

-John

Thanks for the reply. I am not in a rush, just getting into the Automated
designer.

If you’d like me to test it, I would gladly do it, if not, I can wait for
the next release.

OK, this will be fixed in the next beta.