Toad World® Forums

Insert Statements Option No Longer Works

Type a table name into an editor window, press F4 to describe it. Select the “Script” tab and the options icon. Select the “Tables” tab and check the Insert Statements checkbox and click ok.

Previous behaviour was that insert statements would be generated for all of the data in the table; using 12.9.0.43 this no longer happens. I don’t know when this stopped working - it’s not something I use every day but it is a useful function.

While you’re fixing that, would it be possible to enhance it slightly so that if you have applied a filter to the table, only insert statements are generated for the rows currently being returned? I’m currently working on a small project where I set up some data in bespoke tables using a screen in Oracle eBiz. To move the data to another database, I just want to describe the table, filter it to the rows I’ve just created and then generate the insert statements for them. Currently (or I should say previously when it worked!) it will generate insert statements for the entire table which could be thousands of rows and then I have to find the few I need.

Thanks,

Mark.

While you’re fixing that, would it be possible to enhance it slightly so that if you have applied a filter to the table, only insert statements are generated for the rows currently being returned?

For that you have a SQL query and export option

I feel a lesson coming on! Can you enlighten me?

It’s fixed for next beta, but I think it’s best to not apply the grid filter there. The filter on the data tab just feels too far away from the insert statements that come with the script tab to be intuitive. Seems like someone could easily expect it to work the way it does now and not realize that they aren’t getting all of the rows.

But an easy thing you can do - turn off the insert statements on the script tab, and get them from the data tab by right-clicking on the grid and choosing “Export Dataset”, then set it to insert statements. If you do it that way, it will follow your grid filter.

Ahh thanks John - didn’t even realise you could do that! I’m guessing that’s what Damir was talking about.