Toad World® Forums

AV in Schema Browser

The log shows invalid pointer. The initial popup was AV reading address FFFFFFFFFFF. Clicked OK, got Invalid Pointer popup, another AV and Toad stop responding.

EurekaLog 7.0.7.1

Application:

1.1 Start Date : Mon, 13 Jul 2015 08:33:00 -0500
1.2 Name/Description: Toad.exe - (Toad™ for Oracle®)
1.3 Version Number : 12.8.0.8
1.4 Parameters :
1.6 Up Time : 2 day(s), 8 hour(s), 1 minute(s), 42 second(s)

Exception:

2.1 Date : Wed, 15 Jul 2015 16:34:43 -0500
2.2 Address : 0000000004196768
2.3 Module Name: Toad.exe - (Toad™ for Oracle®)
2.5 Type : EInvalidPointer
2.6 Message : Invalid pointer operation.
2.7 ID : CDD00000
2.8 Count : 1
2.11 Sent : 0

User:

3.2 Name : CHX
3.3 Email:

Active Controls:

4.1 Form Class :
4.2 Form Text :
4.3 Control Class:
4.4 Control Text :

Computer:

5.2 Total Memory : 8453214208 (7.87 Gb)
5.3 Free Memory : 965132288 (920.42 Mb)
5.4 Total Disk : 250056704000 (232.88 Gb)
5.5 Free Disk : 128039370752 (119.25 Gb)
5.6 System Up Time : 3 day(s), 14 hour(s), 19 minute(s), 39 second(s)
5.7 Processor : Intel® Core™2 Duo CPU E8400 @ 3.00GHz
5.12 Virtual Machine:

Operating System:

6.1 Type : Microsoft Windows 7 (64 bit)
6.2 Build #: 7601

Steps to reproduce:

8.1 Text:

Call Stack Information:

|Methods |Details|Stack |Address |Module |Offset |Unit |Class |Procedure/Method |Line |

|*Exception Thread: ID=12944; Parent=0; Priority=-2 |
|Class=; Name=MAIN |
|DeadLock=0; Wait Chain= |

Comment=
7FFFFFFE
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
Running Thread: ID=7520; Parent=12944; Priority=0
Class=TSendThread; Name=[Unnamed thread] Kind: TThread. Thread function: CSLog.TSendThread.Execute + $0. Thread caller: CSLog.TSendThread.Create + $3C (CSLog.TSendThread.Execute)
DeadLock=0; Wait Chain=thread: [ 1D60 / 7520 ] is blocked
Comment=
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
7FFFFFFE
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
Running Thread: ID=11764; Parent=12944; Priority=0
Class=TSaveSettingsThread; Name=[Unnamed thread] Kind: TThread. Thread function: tdSaveSettings.TSaveSettingsThread.Execute + $0. Thread caller: tdSaveSettings.TSaveSettingsThread.Create + $3C (tdSaveSettings.TSaveSettingsThread.Execute)
DeadLock=0; Wait Chain=thread: [ 2DF4 / 11764 ] is blocked
Comment=
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
7FFFFFFE
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
Running Thread: ID=12776; Parent=12944; Priority=0
Class=TWorkerThread; Name=[Unnamed thread] Kind: TThread. Thread function: VirtualTrees.TWorkerThread.Execute + $0. Thread caller: VirtualTrees.TWorkerThread.Create + $42 (VirtualTrees.TWorkerThread.Execute)
DeadLock=0; Wait Chain=thread: [ 31E8 / 12776 ] is blocked
Comment=
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
7FFFFFFE
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040

Is it repeatable? Looks like the error occurred while settings were being automatically saved.

I had been doing something else and came back to Toad, scrolled in SB LHS and clicked on a table or package when this happened. Hadn’t been modifying options. I didn’t do anything unusual that I recall, so unlikely I can reproduce this error at will.