Toad World® Forums

Beta Released (12.12.0.16)

Beta Notes

Compare Schemas

Compare Schemas (Legacy) and Compare Multiple Schemas have been combined into a single window.

Details here:� [http://www.toadworld.com/products/toad-for-oracle/b/weblog/archive/2017/07/14/new-in-toad-12-12-beta-updated-compare-multiple-schemas]

Formatting/Parsing (QP5)

  • Improved syntax check on PLS_INTEGER data type usage. E.g. its usage is no longer allowed in CAST expressions.

  • Fix: The function LISTAGG can now have one argument as well.

  • Formatting enhanced for some or all forms of:
    CREATE TABLE
    ALTER TABLE (each clauses on its own line)
    CREATE DATABASE
    ALTER DATABASE
    TRUNCATE TABLE
    CREATE SEQUENCE
    ALTER PROCEDURE
    ALTER INDEX

  • Formatter fix (QP-2556) : CREATE VIEW and CREATE MATERIALIZED VIEW had different column arrangements. Both have been unified.

  • Formatter fix (QP-2527) : CREATE TABLE: Column alignment broken in drop 5.307.

  • Formatter: Model clause formatting enhanced.

  • Fix (QP-2460) : Rule 2831 (“Use PLS_INTEGER instead of INTEGER or equivalent subtypes.”) No longer raising in CAST(… AS data-type), and in column definitions or attributes found in CREATE/ALTER TABLE, CLUSTER, TYPE … and perhaps a few more clauses or statements.

  • Fix (QP-2398) : Rule 2118 (“Avoid DDLs other than Truncate, Exchange/Split partition.”) Will now process DDL quoted inside an EXECUTE IMMEDIATE statement only, excluding all other DDL statements.

  • Fix (QP-2553) : Access violation during legacy rule processing when having a token larger than 1,000 characters in the input text. The new limit is 500 KB.

Slight hiccup there, but the beta released is 12.12.0.16 contrary to what the subject says.

Toad thinks my current version, 12.12.0.15, is the latest beta available.

That should correct here shortly. Check again in few mins.

Toad recognizes there is a newer version (.16) but when it’s downloaded and installed, it’s still at .15, and then it says there’s a newer version.

I’ve tried this several times in the past few minutes without success. Also, the forum Overview page, Update Beta still indicates Last Updated 21-Aug

Ugh. We’re looking at it. Our release pipeline consists of a build followed by a deployment after build validation. The correct build was produced internally, but somehow our deployment got behind one version from the build.

Michael

Try this one Dale. It looks like it worked… the timestamp of files on ToadWorld web page are updated at least.