Toad World® Forums

Build Script on Analyze All Objects Generates Double /

I filtered for a couple of tables in Analyze All Objects and the Generate Script produces 2 slashes resulting in double execution. Also, ACTIVITY_DATE_ACT_CD_IDX is not in the filtered list. It is the first in the schema. I filtered on 2 Table Owners. I’m still stuck in 12.6 :frowning:

BEGIN
SYS.DBMS_STATS.GATHER_INDEX_STATS (
OwnName => ‘BAIM’
,IndName => ‘ACTIVITY_DATE_ACT_CD_IDX’
,Estimate_Percent => SYS.DBMS_STATS.AUTO_SAMPLE_SIZE
,Degree => 20
,No_Invalidate => FALSE);
END;
/
/

BEGIN
SYS.DBMS_STATS.GATHER_INDEX_STATS (
OwnName => ‘BAIM’
,IndName => ‘COMPONENT_IDX1’
,Estimate_Percent => SYS.DBMS_STATS.AUTO_SAMPLE_SIZE
,Degree => 20
,No_Invalidate => FALSE);
END;
/
/

BEGIN
SYS.DBMS_STATS.GATHER_INDEX_STATS (
OwnName => ‘BAIM’
,IndName => ‘COMPONENT_PK’
,Estimate_Percent => SYS.DBMS_STATS.AUTO_SAMPLE_SIZE
,Degree => 20
,No_Invalidate => FALSE);
END;
/
/

I can reproduce the double-slash in 12.6, but not in the current version, so it’s been fixed.

As for the filter - you’re right, the filter doesn’t prevent things from showing up in the script. Uncheck the ones that you don’t want to see in the script. The fastest way to do that would be to multiselect them then rt-click in the header column where the checkboxes are, and choose “uncheck selected”.