Schema Browser - Script not obeying setting(i think)

I go to schema browers "script" tab. I have the setting set to format objects. But when I first go into the tab, nothing is formatted. I need to click "format" to format the script. Am I doing something wrong

1st click:

After format(ctrl 'f')

my settings:

Check the options in your screen shot again. You have "One line per statement" checked. Uncheck that.

Thank you. I did not think "one line" was the issue.

2nd issue, same place. (I hit enter before I finished typing)

how do I get "compute statistics" when in the same tab for indexes.

Looks like that's not possible. There is a setting in script options if you go to SB-Indexes-Script, but it's not accessible from tables. I can add that.

I might be wrong, but in the past, the settings used by the "script" tab was the same as "export ddl"

I must have used the SB index tab, but I a rarely use that tab and I would drill down to the table prior the index. I must be wrong. Thanks.

If you go to SB-Tables-RHS-Indexes, then click the first toolbar button you can get the Compute Statistics option there. That's the only other way that I can think of.