Toad World® Forums

Cancel Query

Hello,

I use to be able to cancel my query in Toad before I am now noticing it’s not working like it use. I am not sure if this is a TOAD issue or a Db2 z/OS issue. I know I can’t cancel threads on z/OS, but Toad was always good about canceling my query after the warning of records being pulled back.

If I run a query that takes a long time I get the following message:

ToadMessage.png

I would then say Yes.But now it seems like my query has canceled but i can’t run any other queries unless I force close out of Toad via task manager.

I never had this issue before 6.3, but I am not sure like I said if its related to 6.3 or some change on the RDBMS.

Thanks for your help.

Toad for DB2 6.3.0.269 (64 bit) for z/OS.

Hi Robert,

This is an old /new issue. Previous to version 6.2 this happened to me all the time. In version 6.2 this got corrected, and now I’m experiencing it again.

Another issue that came back ( I think), is when I run a script across many schema(s). If one of the files is empty, it hangs. This was corrected in version 6.2 and got messed up in version 6.3.

I am not going to stop using version 6.3 as the compare to excel feature makes life much easier for me, but I would like the big boys to check this out.

Have a great day,

Shimon J.

Good Morning Shimon,

That is good to know! Thanks for the information. Hopefully they can fix it quickly. I am enjoying 6.3 and going back to 6.2 is something I want to do.

Thanks for the information. This has been addressed and the fix is in our v6.5 beta.

You can download the beta at:

http://www.toadworld.com/products/toad-for-ibm-db2/toad_for_ibm_db2_beta_program/

Thanks!

Hi Jeff,

Using the 6.5 beta, I’ve had trouble cancelling a script, and the automation script still freezes if there is an empty SQL file in one of the nodes.

I’ll continue using the 6.5 beta and report otherwise if I find the problems corrected.

Sincerely,

Shimon

Shimon,

Thanks for the feedback - the automation issue when there is an empty SQL file has not yet been addressed.

I will review with the team that the cancelling fix made this first beta drop.

Thanks,

Jeff

Shimon,

Can you send in your automation script and steps on how to recreate this - as we cannot yet create this in house.

You can either post those or email those to me at jeff.podlasek@[mention:def66d60eb544ed49068355523d182dd:e9ed411860ed4f2ba0265705b8793d05]

Thanks,

Jeff