Toad World® Forums

Impossible to Cancel a Query

Like many posts on this forum I'm unable to cancel any queries; this started after replacing my work laptop, the version I'm using for Toad is exactly the same as my old one, I connect to over 10 oracle dbs and all are having the same problem where they have worked before; unfortunately our company support teams couldn't resolve this issue after re-installing, I let the cancelation run for two days over the weekend and it never ended; I have to force terminate the application anytime I cancel a query, I do cancel queries a lot, 10+ times per day.
image

I suspect a connectivity issue with either sending the cancel notification to the database or receiving it back, knowing it used to work I haven't contacted the db administrators since it's also affecting multiple dbs.

Toad for Oracle - 64bit version 14.0.75.662

side note, another different behavior I'm seeing is when I login to any database the default schema is not selected by default rather the login username/schema is selected; regardless if I set the default schema or not the editor is no longer looking at the default schema rather using the login information, I looked up that issue as well but most forums say it's not supposed to work that way, while it was working for me, not the end of the world as it's not as bad as canceling a query.

Any suggestions on what I can do to resolve or rootcause the problem would be appreciated. Cheers!

Hi Hassan,

Others have reported this too and we don't know the cause. You may be in a unique position to help figure it out since you just changed laptops and it went from not-working to working.

What is different between your old and new laptop? I mean, besides hardware...

-John

Thanks for the quick response, aside from the hardware I don't believe there's much difference, same version of windows, mostly the same software installed. I tried a few things and found a way to cancel the query without having to force terminate the window but it's not ideal, hopefully it gives the smart people out there a hint on the rootcause.

While cancel pending, select window and alt+f4
image
This will cause the window to close and the application to crash, attempt to close the suspended application using the X (could take a couple of minutes before windows lets you click on the X to close)
image
Click try to restore the program and wait another minute, the application state is restored, the db connection is lost and the following error is displayed "OCI_INVALID_HANDLE"
image
Finally, checking query viewer, I see the following end times for my cancelled query


This is still better than terminating the window and losing all my work in progress queries, it's worked three times in a row so hopefully it works consistently.

For anyone else running into this issue, good luck with the hunt!

Hi Hassan,

I just increased your trust level on the forum. You should be able to edit your message and add the missing screen shots back in. Let me know if that doesn't help.

-John

Is there any change in network settings? security or monitoring software?

No changes as far as I can tell, I still have access to my old laptop and feature is still working. Few things I've attempted are importing user settings, disabling firewall, manually moving user files located in %Appdata%, using the same version of instaclient, messing around with software settings. If anything else comes to mind I could try it later; I'm able to cancel queries executed as a script, just need to get used to adding this condition to all my queries "and rownum < 200" while testing and use F5 instead of CTRL+Enter

just tossing some ideas out there, I'm not sure if any of these are it:

  • wired vs wireless netowrk?
  • TCP/IP settings (control panel -> Network Connections -> ethernet -> properties -> IPV4 )?
  • Windows user account differences? (admin vs not?)
  • SQLNet.ora?

By the way, I tested the default schema and for me that's working in version 14.0.
I set it by finding the schema that I want in the schema browser and right-clicking here
image

Then when I open the Editor on that connection, it's automatically selected in the toolbar.

If you are seeing something different, please let me know.