Toad World® Forums

Cannot change date/time displayed format - SQL Navigator 6.5.0.2090

I am on SQL Navigator version 6.5.0.2090.

On View/Preferences/User Interface, I have the following settings:
Date Displayed Format = “09/05/2012 (MM/DD/RRRR)”
Time Displayed Format = “10:29:35 am (HH12:MI:SS PM)”
Display Time in DATE fields = “Always”

However, when I query any table with a date field, it returns “DD-MM-YY” format in the data grid.

I have played around with different date/time displayed formats, and regardless of what I set them to, my data is still displayed as “DD-MM-YY”.

What am I missing?

Hi Angie,

There is another preference under General > Session, called Default date format; it looks like it’s been changed to DD-MM-YY. You can reset it to or explicitly to MM/DD/RRRR and will get the desired result.

Hope this helps,
Roman

PS. You can also make sure that the preference Code Editor > SQL Scripts > Retrieve all fields as strings is NOT checked. This will allow you to sort columns in the data grid according to their data type.

Message was edited by: roman

Hi Roman,

I had the General/Session/Default date format = . I tried changing it to other date formats and the dates still display as DD-MM-YY regardless. I also tried restarting the application after changing the settings. It is as if the application is not pointing to the preference file that I am updating.

Anyone know where I can find the preference file that the app is using?

Thanks,
Angie

Hi Angie,

Preferences in SQL Navigator are stored in the system registry, not in a file. In most cases, the change in preferences is applied immediately, sometimes - after opening a new session or a new editor window, etc. If you restart, they will be applied for sure.

I think there’s something else that changes your date format setting. For example, it can be a startup script. In any case, if you disable the other setting I mentioned (Retrieve all fields as strings), you should get dates displayed in your UI setting and not in the NLS date format set on the Oracle server.

Regards,
Roman

Disabling “Retrieve all result fields as strings” in Preferences/Code Editor/SQL Scripts fixed the issue!

Thank you Roman!

Angie

1 Like